0

For version 6 i get this message:

virtualbox-6.0 : Depends: libqt5opengl5 (>= 5.0.2) but it is not installable
                  Recommends: libsdl-ttf2.0-0 but it is not installable

ubuntu software center / synaptic have version 5 though 6 exists and no version 5 or 6 gets installed

For version 5 i get this message:

The following packages have unmet dependencies:


virtualbox-qt: Depends: virtualbox (= 5.2.18-dfsg-2) but 5.2.18-dfsg-2 is to be installed
               Depends: libgcc1 (>= 1:3.0) but 1:8.2.0-7ubuntu1 is to be installed
               Depends: libqt5core5a (>= 5.11.0~rc1) but 5.11.1+dfsg-7ubuntu1 is to be installed
               Depends: libqt5gui5 (>= 5.4.0) but 5.11.1+dfsg-7ubuntu1 is to be installed
               Depends: libqt5opengl5 (>= 5.0.2) but it is not going to be installed
               Depends: libqt5widgets5 (>= 5.11.0~rc1) but 5.11.1+dfsg-7ubuntu1 is to be installed
               Depends: libqt5x11extras5 (>= 5.6.0) but 5.11.1-2 is to be installed


**from synaptic manager, i get this message**

virtualbox:
 Depends: virtualbox-dkms but it is not going to be installed or
    virtualbox-source but it is not going to be installed or
    virtualbox-modules
 Depends: libgsoap-2.8.60  but it is not installable
 Depends: libvncserver1 (>=0.9.10) but it is not installable
 Recommends: virtualbox-qt but it is not going to be installed
 Recommends: libqt5opengl5 (>=5.0.2) but it is not installable

apt-cache policy virtualbox virtualbox-qt virtualbox-5.2 virtualbox-6.0 OUTPUT

virtualbox: Installed: (none) Candidate: 5.2.18-dfsg-2 Version table: 5.2.18-dfsg-2ubuntu18.10.1 -1 100 /var/lib/dpkg/status 5.2.18-dfsg-2 500 500 http://archive.ubuntu.com/ubuntu cosmic/multiverse amd64 Packages virtualbox-qt: Installed: (none) Candidate: 5.2.18-dfsg-2 Version table: 5.2.18-dfsg-2ubuntu18.10.1 -1 100 /var/lib/dpkg/status 5.2.18-dfsg-2 500 500 http://archive.ubuntu.com/ubuntu cosmic/multiverse amd64 Packages virtualbox-5.2: Installed: (none) Candidate: 5.2.26-128414~Ubuntu~bionic Version table: 5.2.26-128414~Ubuntu~bionic 500 500 http://download.virtualbox.org/virtualbox/debian cosmic/contrib amd64 Packages virtualbox-6.0: Installed: (none) Candidate: 6.0.4-128413~Ubuntu~bionic Version table: 6.0.4-128413~Ubuntu~bionic 500 500 http://download.virtualbox.org/virtualbox/debian cosmic/contrib amd64 Packages 100 /var/lib/dpkg/status

  • Please add outputs of apt-cache policy virtualbox virtualbox-qt virtualbox-5.2 virtualbox-6.0 to the question. – N0rbert Apr 1 '19 at 17:17
  • Looks like you don't have the cosmic-updates repo enabled. Three of those packages I checked are older versions. Be sure you have cosmic-security enabled also. Do you have a specific preference which version of Virtualbox you want? Or is the Ubuntu default okay? The most common reason for this kind of problem is a wrong-version or non-Ubuntu source. Not every deb is compatible with every version of Ubuntu.. – user535733 Jun 15 '19 at 21:41
  • apt-cache policy virtualbox virtualbox-qt virtualbox-5.2 virtualbox-6.0 PRINTS virtualbox: Installed: (none) Candidate: 5.2.18-dfsg-2 Version table: 5.2.18-dfsg-2ubuntu18.10.1 -1 100 /var/lib/dpkg/status 5.2.18-dfsg-2 500 500 archive.ubuntu.com/ubuntu cosmic/multiverse amd64 Packages virtualbox-qt: Installed: (none) Candidate: 5.2.18-dfsg-2 Version table: 5.2.18-dfsg-2ubuntu18.10.1 -1 100 /var/lib/dpkg/status 5.2.18-dfsg-2 500 500 archive.ubuntu.com/ubuntu cosmic/multiverse amd64 Packages – planet rocker Jun 17 '19 at 9:51
  • virtualbox-5.2: Installed: (none) Candidate: 5.2.30-130521~Ubuntu~bionic Version table: 5.2.30-130521~Ubuntu~bionic 500 500 download.virtualbox.org/virtualbox/debian bionic/contrib amd64 Packages virtualbox-6.0: Installed: (none) Candidate: 6.0.8-130520~Ubuntu~bionic Version table: 6.0.8-130520~Ubuntu~bionic 500 500 download.virtualbox.org/virtualbox/debian bionic/contrib amd64 Packages 6.0.4-128413~Ubuntu~bionic -1 100 /var/lib/dpkg/status – planet rocker Jun 17 '19 at 9:51
0

Try downloading it off there website here; https://www.virtualbox.org/wiki/Linux_Downloads

Then click Ubuntu 18.04 / 18.10 / Debian 10

Run the file that downloads. The one on the Ubuntu Software center did not work for me to. But that one did

  • i already did that :( – planet rocker Apr 2 '19 at 9:37
  • it cannot get installed – planet rocker Apr 3 '19 at 15:55
  • Whats the error message that is showing up? If there is one. – IWick Apr 6 '19 at 1:03
  • in short words i always get the message, cannot locate and install packages libqt5opengl5 or libsdl-ttf2.0-0 even after adding the "right" repositories – planet rocker Apr 11 '19 at 12:39
0

This worked for me.

apt --fix-broken install

Hopefully that helps you.

  • no does not work, this VB version cannot get more arab – planet rocker Jun 17 '19 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.