4

I am having a hard time finding an answer to this question for 18.04 LTS.

I used the following to find a list of options to configure.

gsettings list-keys org.gnome.desktop.peripherals.touchpad

It returned the following list:

touchpad send-events natural-scroll tap-to-click two-finger-scrolling-enabled left-handed click-method speed scroll-method tap-and-drag edge-scrolling-enabled disable-while-typing

Out of this list, which of these options can be configured to be "false" to disable horizontal scrolling? Samuel Cavazos' answer seems close to what needs to be done, but the horizontal option does not appear to be available in the current list above. His answer, which is not applicable in 18.04, is as follows:

gsettings set org.gnome.settings-daemon.peripherals.touchpad horiz-scroll-enabled "true"

Was this option renamed to scroll-method? If so, what should the terminal line be to disable horizontal scrolling?

3

I found the answer to my own question, and so wanted to share what worked for me in case others are stuck. Pilot6's answer to the same question asked for 16.04 works with a little modification for 18.04. The following steps solve the issue:

  1. Install "libinput-tools" (this package name is slightly different from 16.04) and dependencies in terminal by running the following commands:

sudo apt update

sudo apt install libinput-tools

  1. Then enter the following line in terminal

sudo gedit /usr/share/X11/xorg.conf.d/40-libinput.conf

  1. The file will open in text editor. In the touchpad section, just before the line indicating the end of the section, add the following line:

Option "HorizontalScrolling" "False"

  1. Save and close the configuration file and restart. Horizontal scrolling should be disabled.
  • Thanks for this. There's a small typo in step 2 though - "x11" should be "X11" (capital X). – iGadget Apr 20 at 10:25
  • Thank you, good catch! The typo was corrected. – OpnSrcFan Apr 21 at 13:26
0

OpnSrcFans Solution worked for me, however only under the circumstance that I used the Ubuntu Desktop without Wayland and that I explicitely changed the Driver Option in the 40-libinput.conf file from libinput to synaptics

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.