3

I want to fix this because it seems the reason why I cannot share ubuntu folders with my Windows machine.

Windows 7 machine network configuration:

IP: 192.168.2.2
Subnet Mask: 255.255.255.0
Gateway: 192.168.2.1

dns: 8.8.8.8, 4.4.4.4

Ubuntu machine network configuration:

IP: 192.168.2.3
Subnet Mask: 255.255.255.0
Gateway: 192.168.2.1

dns: 8.8.8.8, 4.4.4.4

I can ping my Windows machine from Ubuntu but I cannot ping my Ubuntu machine from Windows.

Any suggestions?

2
  • Are you pinging by hostname or by IP? What is the exact error when you try to ping?
    – pestilence
    Mar 14, 2012 at 19:05
  • Can you post the result of the following command : iptables -L ? Mar 14, 2012 at 19:14

2 Answers 2

5

Maybe your iptables (aka Firewall) has rule for blocking ping requests.
You can check it easily by disabling the iptables with the command sudo ufw disable. Run the ping test again.
Enable it again with sudo ufw enable.

2
  • It worked like a charm. I will have to learn now how to add my windows machine to the iptables in order to reactivate the firewall. Thanks!
    – rfc1484
    Mar 14, 2012 at 21:20
  • 1
    Can you also describe how to remove this ping block rule?
    – Naveen
    May 28, 2014 at 13:55
0

4.4.4.4 is not a Google DNS, Google now has established public DNS servers at 8.8.8.8, and 8.8.4.4 can additionally be used.

1
  • No, it's a Level 3 DNS, but I've read that Level 3 DNS servers shouldn't be used. Mar 1, 2015 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.