1

I have the problem that my laptop, a Compaq 615, gets very hot since I installed Ubuntu 18.10. I already tried various solutions but with no success.

the sensors command says me that the system is in idle mode above 75 °C. The fan is always blowing. If I have a website with some scripts or several tabs active etc it goes up to 90 °C. If I open a youtube video the system heats up to 98 °C

Previously Win7 was installed I remember there the temperatures during youtube videos were around 80 °C and in idle 55 °C

I tried this: [Laptop running very hot with Ubuntu

I also installed xubuntu because it uses less resources but it is the same problem there.

I changed the grub file like they explain here: GPU overheating with the open source radeon driver

to this

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=1"

or this: https://forum.ubuntuusers.de/topic/update-bionic-laptop-nur-noch-heiss/

and around 10 more articles about that problem that I can't find anymore. It seems that it is a problem with the video driver.

The laptop has a Radeon mobility HD 3200 inside. I tried to install the official driver which is a .run file with./ but there is a problem with the versions.h because the files are now relocated in this ubuntu version.

fglrx installation requires that the system have kernel headers. /lib/modules/4.18.0-16-generic/build/include/linux/version.h cannot be found on this system.

I found this article where someone had that problem Amd graphics card installation error on ubuntu 15.10

but it did not work. After I did it I could install the driver but it told me that some errors occurt during installation (but not which). After a restart I just had the console version but the desktop was gone. I had to reinstall the system.

Then I tried this https://linuxconfig.org/how-to-install-amd-radeon-drivers-on-ubuntu-18-10-cosmic-cuttlefish-linux

But nothing works. Now I can't even install the driver anymore because of stuff I did and don't remember. It says:

error: Detected X Server version 'XServer _64a' is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib32:XServer _64a:none:4.18.0-16-generic:) Installation will not proceed.

Removing temporary directory: fglrx-install.iKW51z

The card is recognized correctly

01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RS780M [Mobility Radeon HD 3200] [1002:9612] (prog-if 00 [VGA controller])

So far no solution

2
  • I lower the CPU frequency to cope with the overheating. manpages.ubuntu.com/manpages/bionic/man1/…
    – kenn
    Mar 29, 2019 at 21:05
  • I'd first check your BIOS version. See here for version F.20. Also, if there's a lot of dirt/dust inside the computer, you may have to open the laptop and blow it out with compressed air. Worst case the thermal paste on the CPU may need refreshing. Lastly, you could install thermald and see if that can keep the temps down. Report back.
    – heynnema
    Mar 29, 2019 at 21:10

1 Answer 1

0

here is an update. And the solution

First I did never try to install the drivers offerd on the HP website. I always tried the on by ATI. Well but also there is a problem while installing the one from HP. I think the problem with the standart driver is, that it does not use the mobility versions of the graphics cards correctly! Because on another computer with a ATI card (but a normal one) I have temperatures around 45 °C in idle

So then I tried the solution with the CPU frequency but I did not really understand how to use it. But it brought me to another idea. Because also I do not want to limit the frequency. After some search I found this:

How do I set the CPU frequency scaling governor for all cores at once?

And that did the trick! Now I have temperatures around 65 °C in idle. And using firefox with multiple tabs around 70 °C. That is okay for me.

I did exactly this:

cpufreq-info

to get informations about the CPU's

It says for core 0 and core 1 that both run between 1.8 GHz and 2.2 Ghz ondemand.

Also there are the possible types of usage displayed. Like available cpufreq governors: conservative, ondemand, userspace, powersave, performance

So then I put this line:

sudo bash -c 'for i in {0..1}; do cpufreq-set -c $i -g powersave; done'

the numbers in the {} stand for the cpu cores 0 and 1. (If another CPU has more cores the last numer needs to be the last core (Nr. 3 for a quadcore, 5 for a hexacore))

with cpufreq-info

I checked again and now both cores run in powersave between 1.8 GHz and 2.2 GHz

Oh and by the way. I changed to Kubuntu 18.04 LTS. Because I messed up the system before while trying solutions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.