0

While installing workspaces to dock (an extension of Gnome shell) , I needed to restart gnome shell and it became unresponsive after restarting using alt+F2 r enter - ubuntu 18.04

Only mouse is moving , no clicks working , no keyboard keys working (except function keys, ctrl , alt).

My question is, How do I completely restart gnome shell to make it function properly?

I also tried other methods to restart such as

sudo service gdm restart
sudo service gdm3 restart
gnome-shell --replace
sudo service lightdm restart
sudo /etc/init.d/gdm3 restart
systemctl restart gdm.service

And many more. By using shell by pressing ctrl + alt + f4, but none worked.

On restarting, the system is loaded and the GUI also, but everything is again unresponsive.

I also tried entering the terminal using recovery mode and updating the system and restarting all the services but none proved helpful.

Everything works fine till the login screen, however entering the password take me to my regular desktop, which is as I told is unresponsive again. No components of GUI seems to be broken, yet it is unresponsive.

Notifications such as a new e-mail arrived are also popping up , but none of my input is accepted, even I can't restart the system using Graphical interface.

What I can access is the text console by pressing ctrl + alt + F4

  • It appears as if your extension is causing the issue. You will need to have the extension fixed. – vanadium Mar 29 at 9:43
  • but that extension has nothing to do with shell I am sure, as i was using it already , and this was just a reinstall of the same. @vanadium – root-user Mar 29 at 11:08
  • Does it happen also when the extension is disabled? – vanadium Mar 29 at 12:14
  • Actually I can't do anything just watching the time at the top , everything is like paused . I am unable to do any action there. I strongly think , this happened due to restarting the shell(as I did the shell restart like this the first time) , as soon I restarted the shell it showed RESTARTING at screen and then it everything got seized for me. I could see my work open, downloads going on. Everything seemed normal, but what I ultimately was able to do , was a power button press and restart because no keys , or mouse clicks were working. (Except the mouse pointer was moving normally) – root-user Mar 29 at 12:24
  • 1
    And what happens after you restart the computer? Unresponsive as soon as you log in? Please provide information by editing your question. Anyone reading this is not in front of your computer. – vanadium Mar 29 at 12:56
0

Boot to Recovery Mode from the GRUB Advanced Options menu.

At the # prompt, type:

sudo mount -o rw,remount / # remount the disk r/w

cd /home/your_username/.local/share/gnome-shell/extensions # change directory

ls -al *workspace* # identify the Workspaces to Dock GNOME extension directory

sudo rm -r the_name_of_the_workspaces_extension # remove the GNOME extension

reboot # reboot the computer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.