2

I want to use tensorflow-gpu 1.13, but it needs cuda 10.0, not cuda 10.1 to work. My GPU is GeForce RTX 2070, ubuntu version 18.04. Until now I worked with CUDA 10.1 (that's are nvidia-418 drivers) and tf-gpu 1.12. Tried to purge nvidia drivers and install older ones- nvidia-410, but ubuntu is overwriting it again to 418. It was like:

sudo apt-get purge nvidia*
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-410
reboot

and after

nvidia-smi

still got CUDA 10.1

Have you any ideas or solution how can I install CUDA 10.0? Grateful for help!

  • 2
    After reboot, try this command: lsmod | grep nvidia . If there is no output, then your installation has probably failed. – Marmayogi Mar 28 at 18:56
  • If a package is marked "hold", it is held back and the package cannot be installed, upgraded, or removed until the hold mark is removed. Now try again with these sequence of commands: 1) sudo apt-get purge nvidia* 2) sudo add-apt-repository ppa:graphics-drivers/ppa 3) sudo apt-get update 4) sudo apt-get install nvidia-410 5) sudo apt-mark hold nvidia-410 and finally 6) Reboot. Issue command:lsmod | grep nvidia. If there is output, then your installation is successful! If you want to unhold, @Kacper, then issue command at any time: sudo apt-mark unhold nvidia-410. – Marmayogi Mar 28 at 19:56
  • You said in your post that after installing nvidia-410, however ubuntu was overwriting it again to 418. So let us play apt-mark hold nvidia-410 and see Ubuntu is really capable of overwriting with 418 in spite of hold command! – Marmayogi Mar 28 at 21:04
  • Thanks for answer. I did as You said, checked "lsmod | grep nvidia"- gives me ouput... But still my nvidia drivers are 418 and CUDA 10.1. – Kacper Mar 29 at 7:57
  • Can you please post the output of lsmod | grep nvidia? @Kacper, your problem still persists nevertheless we will try to find out a solution. – Marmayogi Mar 29 at 9:13
0

OK, sorry for my absence. solved this, just one day after asked question. first of all i removed whole nvidia drivers (purge), then I made repository for graphics drivers and followed this code :

    Add NVIDIA package repositories
wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/cuda-repo-ubuntu1804_10.0.130-1_amd64.deb
sudo dpkg -i cuda-repo-ubuntu1804_10.0.130-1_amd64.deb
sudo apt-key adv --fetch-keys https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/7fa2af80.pub
sudo apt-get update
wget http://developer.download.nvidia.com/compute/machine-learning/repos/ubuntu1804/x86_64/nvidia-machine-learning-repo-ubuntu1804_1.0.0-1_amd64.deb
sudo apt install ./nvidia-machine-learning-repo-ubuntu1804_1.0.0-1_amd64.deb
sudo apt-get update

# Install NVIDIA driver
sudo apt-get install --no-install-recommends nvidia-driver-410
# Reboot. Check that GPUs are visible using the command: nvidia-smi

# Install development and runtime libraries (~4GB)
sudo apt-get install --no-install-recommends \
    cuda-10-0 \
    libcudnn7=7.6.0.64-1+cuda10.0  \
    libcudnn7-dev=7.6.0.64-1+cuda10.0


# Install TensorRT. Requires that libcudnn7 is installed above.
sudo apt-get update && \        
        && sudo apt-get install -y --no-install-recommends libnvinfer-dev=5.1.5-1+cuda10.0

code from: https://www.tensorflow.org/install/gpu

when i check drivers nvidia-smi, I still got CUDA 10.1, but tensorflow-gpu == 1.13 works well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.