0

So I had initially set my keyboard to Switzerland (French- Macintosh) which worked almost on point (some commands did not correspond), but a few days ago, I woke up to a keyboard layout that was completely different (I think the one classically used in Windows OS, Shift+1=! Shift+2=@ etc.), despite the same layout being selected and used.

Any ideas on how to fix this? I've the latest version of Ubuntu (running on VirtualBox).

Screenshot keyboard:
Screenshot keyboard

Screenshot settings page:
Screenshot settings page

  • could you add a sreenshot of the whole window where you can see that "Switzerland (French- Macintosh)" is selected? – tatsu Mar 28 '19 at 16:23
  • Hey tatsu, thanks for your reply. Find the screenshots included. So by itself I suppose the computer responds correctly to the keyboard that's displayed. The issue is that it wasn't like that when I first used it (and it is not supposed to be as shown either). Is it a recent update that modified keyboard layouts accidentally or something? – Timmy Mar 28 '19 at 23:30
  • so the layout doesn't correspond to what you expect from French (Switzerland, Macintosh)? yes it's possible the schematic was out of date compared to international norms. I suggest you start looking among the French choices for the one that suits you best if the layout you showed in the picture is not the one you want. "alternate french" (first french) choice has the symbols first and numbers you have to access with shift, which, I imagine, is what you want. – tatsu Mar 29 '19 at 6:55
  • 1
    Yes it is not what I expect. I also just realized that all keyboards, when i display them, have the same layout that I currently have (i.e. even if I try an AZERTY I see the qwerty that I currently use). I guess it is a system-wide problem and not specific to my keyboard layout. – Timmy Mar 29 '19 at 9:58
1

Ok so by running

sudo dpkg-reconfigure keyboard-configuration

(which I had tried before), I needed to select the French-Switzerland default package, as the Macintosh one does not work ('cannot find "fr_mac" in "macintosh_vndr/ch".'). Better than before at least.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.