1

I had installed Kubuntu 18.04 on my old desktop a month ago and it worked pretty fine, everything seemed snappy and Kubuntu brought my old desktop back to life (thank you for that :) ).

I received a notification a few days ago for minor software updates (not the first time) and I approved them. But since then, most of the desktop effects have stopped working completely. The magic lamp (minimizing feature) that I really love is gone now and all the windows do is just disappear when I minimize them. The screen edge highlighter stopped working. These are the two I just miss a lot, each and every one of the desktop effects have stopped working. Moreover, the option to present all windows in a desktop when mouse nears a screen edge has also stopped working.

This is not the first time this has happened to me, I had Kubuntu 17.10 on my laptop (Lenovo Ideapad 100 - Intel i3 Integrated Graphics) a year ago and the same thing had happened on that device too. The desktop effects stopped working after an update and worse, a few weeks after the update my laptop crashed out of nowhere. It refused to boot up into Kubuntu 17.10. I finally gave up and installed Ubuntu 18.04 on that and Ubuntu has been great for me. I really love Kubuntu and I miss the amazing features it offers compared to Ubuntu.

Am I doing something wrong or is it that both my systems are really old?

1

Desktop effects require compositing to be enabled.

You can check the status of compositing by running

qdbus org.kde.KWin /KWin supportInformation | grep -i composit

in your terminal.

$ qdbus org.kde.KWin /KWin supportInformation | grep -i composit
Composite: yes; Version: 0x4
compositingMode: 1
useCompositing: true
compositingInitialized: true
windowsBlockCompositing: true
Compositing
Compositing is active
Compositing Type: OpenGL
$

By, default, Kubuntu has compositing enabled on start-up. That's why compositingInitialized: true appears in the output posted above.

To check whether compositing is enabled on start-up, open System Settings and type composit in the search bar. As you can see in the image below, Display and Monitor is highlighted:

System Settings

Open Display and Monitor and ensure that compositing on start-up is enabled.

compositing enabled on start-up

Note that, for whatever reason, you can toggle compositing on/off by pressing Shift+Alt+F12 at any time.

  • Thanks! But I found something. A warning: "OpenGL composting has crashed Kwin in the past. Most likely due to a driver bug. If you think that you have meanwhile upgraded to a stable driver, you can reset this protection but be aware that this might result in an immediate crash! Alternatively you might want to use the XRender backend instead." It is okay to re-enable OpenGL? Or should I use XRender? – Sreejesh Saya Mar 28 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.