0

I have recently decided to switch to Ubuntu on my personal laptop. I decided to install Ubuntu 16.04 since I was running into issues with version 18.04. After two days, I was able to installed properly on my machine.

I got to add the parameter "pci=noaer" after squash line in the console while booting in order to overcome an error while booting(PCIe bus error).

After that, I was able to use & connect to the internet. After two hours, the internet stopped working. I have try everything & I don't get anywhere.

My network adapter is a RTL8821AE 802.11ac PCIe Wireless Network Adapter. I own a Asus machine and I removed Windows completely so I just have Ubuntu 16.04 installed. Any help will be appreciated it.

I have try updating dependencies, playing with settings, nothing have solved my issue. I am about to quit to be honest.

Edited

Output running the command ip a

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
   valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever
2: enp2s0f2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 2c:4d:54:c2:b7:af brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether f0:03:8c:65:dd:75 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.29/24 brd 192.168.2.255 scope global dynamic wlp3s0
       valid_lft 258495sec preferred_lft 258495sec
    inet6 fe80::e30c:7ed0:aad1:513c/64 scope link 
       valid_lft forever preferred_lft forever

Also try sudo aptitude safe-upgrade -y and it didn't solve the issue.

  • First step is to check whether the wifi hardware is disabled. Depending on the model of the laptop, this could be a FN+KEY combination, a button, or a switch of some sort on the laptop. – rtaft Mar 27 at 18:53
  • what's the output for ip a ? – Tintin Mar 27 at 19:03
  • @Tintin I added the output in my main post. – Manuel Abascal Mar 27 at 19:10
  • Thanks for the addition. Well according to the output your networking modules are working and absolutely being recognized by the system. But what do you mean you can't connect to the internet if you're on a wifi network that's connected to the internet already? – Tintin Mar 27 at 19:17
  • @Tintin it means that I am connected to my Wi-Fi network. The system recognized it. However, I can't browse the internet or download stuff. I mean zero internet. However, I am 100% connected it. It was working the first 2-3 hours post installation. I actually was able to download Chrome, Visual Studio, Nodejs, etc.... – Manuel Abascal Mar 27 at 19:22
0

Solution:

I found the answer to my problem. It seems that I needed to install the proper drivers for my Realtek RTL8188. This is the solution:

sudo apt-get install build-essential linux-headers-generic git dkms
git clone http://github.com/lwfinger/rtlwifi_new.git
cd /path/to/rtlwifi_new
make
sudo modprobe -rv rtl8188ee
sudo make install
sudo modprobe -v rtl8188ee

I figured it out using this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.