0

I am trying to launch and use shotwell on a remote machine from my local machine. From my local machine, I run:

ssh -X <user>@<host> shotwell

The shotwell app shows up and is functional but there is no menu bar. Here's a screenshot of what I see.. This same issue happens with firefox. I also tried with Gvim and the problem does not exist with Gvim.

My local machine is running Ubuntu 16.04 desktop and my remote machine is running 18.04 server. The server is running openssh with X11Forwarding set to yes and X11DisplayOffset defaulting to 10.

I tried adjusting menu bar options on my local machine. Under settings->appearance->behavior there a few menu options that I toggled but that had no affect.

When I run the ssh client command above, I do see the following messages:

Gtk-Message: 02:42:31.576: Failed to load module "canberra-gtk-module"
Gtk-Message: 02:42:31.583: Failed to load module "canberra-gtk-module"

I get these messages even though both machines have libcanberra-gtk-module and libcanberra-gtk3-module installed.

Any ideas?

Thank you in advance.

Update -

The problem does not exist when the local machine is running Linux Mint 19. Shotwell launches with the menu bar. The problem seems to be with Unity..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.