4

I've looked at many similar questions but unfortunately the solutions didn't work for me. I have recently installed Ubuntu 18.04 and my speakers are not working nor they are detected in the settings, they are actually listed as not available after running pacmd command. They are working fine on windows so the problem must be related to the compatibility with the driver in ubuntu, but I suppose there must be some settings to fix it. here ill pastebin what I get from the sinks list:

1 sink(s) available.
  * index: 0
    name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE 
    priority: 9039
    volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
            balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 0
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 371.52 ms
    card: 0 <alsa_card.pci-0000_00_1f.3>
    module: 7
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "ALC255 Analog"
        alsa.id = "ALC255 Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xb4520000 irq 134"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1f.3"
        sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "9d71"
        device.product.name = "Sunrise Point-LP HD Audio"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "Built-in Audio Analog Stereo"
        alsa.mixer_name = "Realtek ALC255"
        alsa.components = "HDA:10ec0255,10251094,00100002 HDA:8086280b,80860101,00100000"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-speakers"
        analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: yes)
            properties:
                device.icon_name = "audio-headphones"
    active port: <analog-output-headphones>

It looks to me like the headphones and the speakers are in the same sink, although as you can see it gives the speaker as not available. Anyone knows how to handle it? I've tried out myself but I'm starting to give up... Here are the details about my sound card

 $ lspci -v | grep -A7 -i "audio"
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
    Subsystem: Acer Incorporated [ALI] Sunrise Point-LP HD Audio
    Flags: bus master, fast devsel, latency 32, IRQ 132
    Memory at b4520000 (64-bit, non-prefetchable) [size=16K]
    Memory at b4510000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_soc_skl
1
  • Maybe is there any alternative driver to pulseaudio and alsa? I also noticed that touch pad's right click isn't working... pff I don't wanna switch back to windows I need to solve this Mar 27, 2019 at 12:06

1 Answer 1

0

For those who have this problem, if the solutions in other similar questions won't work, like using pavucontrol etc., perhaps you need, like in my case, to look in alsamixer if you have auto-mute enabled by scrolling right in the alsamixer playback units, because if it's enabled it is not sufficient to raise the volume of your speaker from the alsamixer to solve the problem. So step one make sure volume of playback unit is not muted.

enter image description here

And STEP TWO make sure that auto-mute is disabled.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.