1

So I have wol working almost perfectly, after I shut down my pc I have approx a one-minute window where my desktop is detected as inactive by my routers 'connected devices' menu and I can send a magic packet and wake up my desktop from a remote computer using.

wakeonlan -i 174.X.XXX.XX -p 9 70:XX:XX:XX:XX:XX

After, the desktop is no longer detected by the router and the only way I can wake the desktop up is if I send the magic packet directly to the mac address from the local network.

For some reason my raspberry pi does not time out on the routers 'connected devices' and always remains visible with inactive status which leads me to believe this could be something related settings on my desktop and not my router. Or is this simply just not possible.

Here is the ethtool readout (which oddly does not show wake-on-settings unless I use sudo)

Settings for enp42s0:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Full 
Supported pause frame use: Symmetric
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Full 
Advertised pause frame use: Symmetric
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
MDI-X: on (auto)
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000007 (7)
               drv probe link
Link detected: yes

I also tried adding this to /etc/default/halt and using sudo poweroff -h from terminal.

HALT=poweroff
NETDOWN=no

I also tried this

  • I have exactly the same problem. First, I think it is possible as I can wake the computer up outside the local network. ie. The wake-on-lan packets are routable. My problem is that my router refuse to connect to the computer after about 1 min suspend. However, I can always wake it up by a broadcast in local network. ie. using .255 IP ending with the wakeonlan command. Now I still cannot wake it up remotely after 1 min... any update on this problem? – Kelvin Apr 14 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.