0

I have a Synology NAS and an Ubuntu 18.04 client and I'm trying to mount the drive via NFS. It mounts well, but I can only see the folders as read-only in Nautilus. Everything in /etc/exports was specified correctly, I'm only sharing one folder to one IP and rw is specified:

admin@DS211:~$ sudo cat /etc/exports
/volume1/pub    192.168.0.205(rw,async,no_wdelay,all_squash,insecure_locks,sec=sys,anonuid=1024,anongid=100)

...then some research suggested that it might have something to do with the usernames and the UIDs being different, so I created a new user with the same UID as the admin user on the NAS to test this, and found I could now create folders on the remote drive -- but only through the terminal and with both my new user and the standard user. I only have read-only access through Nautilus, no matter with which user I open Nautilus. I also tried it through a line in /etc/fstab and get the same result.

:~$ grep pub /etc/fstab
192.168.0.100:/volume1/pub    /media/NAS_PUB   nfs auto,nofail,noatime,nolock,intr,rw,tcp,actimeo=1800 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.