2

OS: Ubuntu 16.04 64bit w/ Gnome Classic

VB: 5.2.26 r128414 (Qt5.6.1)

I have 3 MS Windows VMs running in VirtualBox. These VMs have been running for years. This morning I restarted my system due to updates. When I attempt to run any of the VMs I received this error:

`The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there 
is a permission problem with /dev/vboxdrv. Please reinstall the kernelmodule by 
executing '/sbin/vboxconfig' as root. where: suplibOsInit what: 
3 ERR_VM_DRIVER_NOT_INSTALLED (-1908)
- The support driver is not installed. On linux, open returned ENOENT. The 
VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a 
permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing
'/sbin/vboxconfig'
as root.
where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support 
driver is not installed. On linux, open returned ENOENT.'

When I run the command I receive this error:

`vboxdrv.sh: Stopping VirtualBox services.
`vboxdrv.sh: Starting VirtualBox services.
`vboxdrv.sh: Building VirtualBox kernel modules.
`vboxdrv.sh: failed: Look at /var/log/vbox-setup.log to find out what went wrong.
`There were problems setting up VirtualBox.  To re-start the set-up process, run
/sbin/vboxconfig
as root.

After browsing around here, I decided to downgrade to V5.1, via this post. The Extension Pack fails to install. I was able to get one of the VMs started, but now not even the GUI for VB will run.

Here is the crash log:

virtualbox-5.1.0.crash detected /var/crash/virtualbox-5 VirtualBox Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

From the post I linked, I am attempting the first answer, but the system is not finding the package now:

sudo apt remove virtualbox*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package virtualbox-5.1_5.1.38-122592~Ubuntu~xenial_amd64.deb
E: Couldn't find any package by glob 'virtualbox-5.1_5.1.38-122592~Ubuntu~xenial_amd64.deb'
E: Couldn't find any package by regex 'virtualbox-5.1_5.1.38-122592~Ubuntu~xenial_amd64.deb'

I have attempted the rest of the first answer and after it successfully installs I The following error:

The VirtualBox kernel modules do not match this version of VirtualBox. The installation 
of VirtualBox was apparently not successful. Executing
'/sbin/vboxconfig'
may correct this. Make sure that you are not mixing builds of VirtualBox from 
different sources.
where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) 
- The installed support driver doesn't match the version of the user.   

/sbin/vboxconfig does not fix the issue. And now I cannot remove the testbuild. I am at a loss on where to go next.

  • What kernel do you have? Please add output of uname -r to the question. – N0rbert Mar 25 '19 at 16:58
  • I am currently running 4.4.0-142-generic. I was running .143. I received some advice on the Ubuntu forums to boot into a previous kernel, which fixed my issue for now, until a patch is sent down. Here is the thread of a previous discussion. ubuntuforums.org/showthread.php?t=2415046 – nanu.nanu Mar 25 '19 at 19:32
0

With the current errors that are being shown my suggestion would be to reinstall Virtualbox after completely removing the previous packages.

I've tried using /sbin/vboxconfig but it never really solves the issue even though you run it using root account. The best way to solve it is by installing the guest and host modules available for virtualbox against different version of your kernel.

So to know the current version of your kernel just type uname -r

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.