1

Recently the issue has occurred where launching Foxit Reader does not open an active window on the desktop. Launching it from its .desktop file shows the icon appearing on the Unity bar with an orange dot (I assume indicating the application is running), but clicking on it does not bring up it's window. The Foxit Reader tab also appears on the top panel. Right-clicking the icon in the Unity bar and selecting All Windows does indeed show what I should be seeing on the desktop, but even selecting that does not bring it up. I don't know if there is any way too fix this or perhaps install it's .run file as root? Tried uninstalling it and rebooting followed by a reinstall but nothing seems to work.

  • 2
    Does it work in the default Gnome DE? – user880592 Mar 25 '19 at 13:21
  • @GabrielaGarcia It used to, but even when I click the Activities tab to show all active applications it doesn't show up there. This started happening a few days ago – ManP Mar 25 '19 at 13:32
0

Found the issue to not be related to the software but to the Display settings on Ubuntu. The problem of applications not appearing on screen was occurring with more applications than one. In Display Arrangement there are two screens shown. 1 is Primary Display and 2 is Unknown Display. The presence of Unknown Display extends my screen's active desktop beyond the edge of my monitor, and in that space some applications will open there by default and give the impression that the application is not properly running. After selecting the Unknown Display in settings and turning it off the desktop will then in turn limit its boundaries to the Primary Monitor( That may be Built-in or the relevant name brand)

0

Verify if the process is running: ps -ef | grep foxitreader

Kill the process

Try to open foxitreader again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.