0

Today, when I open google chrome from the unity launcher, it's getting stuck in opening homepage. It hangs for 3 seconds and the option to force quit immediately popup.

I tried opening through terminal, google-chrome-stable command, and it opens normally. I think my launcher icon got replaced. One thing I noticed was its not on the same position as last time. Its now on bottom of the list. Also when I hover on it, the launcher name is now my local IP (192.168.99.10) instead of Google Chrome - web Browser and it lost the option for Open a New Window and Open a Private Window when right clicking it. I suspected it got replaced and now loading my local environment, but I'm not sure why it hangs and cannot proceed.

So I searched my /usr/share/applications directory and find google-chrome.desktop, but upon checking it seems normal.

Exec=/usr/bin/google-chrome-stable %U
Terminal=false
Icon=google-chrome
Type=Application
Categories=Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml_xml;image/webp;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;
Actions=new-window;new-private-window;

I'm not sure what has caused this and how to fix it. I don't want to run google chrome through terminal every time I needed it.

There wasn't any update and the only thing different that I did was running chrome with a flag from terminal last week once:

google-chrome --disable-web-security --user-data-dir="/tmp/chrome_tmp"
0

have solved this by deleting all *.desktop files found here ~/.local/share/applications

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.