1

As the title suggest, my problem is NOT that I cannot boot to my harddrive, or not have access to the boot menu itself, as in when I hit the F12 button on my Lenovo y50-70 touch, the boot menu does reveal itself, also, my primary Win10 OS boots just fine.

The issue i'm having is that after a fresh wipe of my harddisk (I wiped ubuntu 18.10 for Win10 to implement a more practical partition scheme for a multiboot scenario) I had no problems in the past with dual boot for multiple linux partitions and though I was sad to see them go, I felt it was the best direction to go in as top users on this site had recommended. Unfortunately, Win10 seems to load regardless of which selection I make from the boot menu and that it refuses to update/refresh the options regardless of what bootable usb/recovery usb I plug in or unplug.

I used a gpt partition table, and used a win10 Enterprise LTSC iso a'la bootable USB to install win10 along with whatever other editing to my harddisk (create boot partition, etc) and everything seemed to be going great.

However, I noticed that when I had used this USB that it took a few tries in the boot menu, and few sepearate (incorrect) boot options until it did in fact work. It seemed that my boot menu options had been obfuscated somehow. I was sure that it would have refreshed itself as ive never seen it perform like that in the past.

After the install of windows 10, the problem not only persisted, but as i've continued my search on google, it seems as though I cannot find any answers pertaining to my exact situation. I have searched up and down on yt, gl, bing, StackE, but to no avail. Any help is much obliged in advance.

Things I have tried to fix the problem:
- switched AHCI to compatible/vice versa, in the BIOS
- made sure secure boot remained off in BIOS
- refreshed my BIOS settings to default
- made sure USB Legacy was turned ON
- switched from UEFI to compatibility mode/vice versa in BIOS
- turned on start from UEFI-LEGACY/vice versa in BIOS

0

Finally found answers and a fix, all though I have not tried the recommended fix just yet, as I was lucky enough to have one of my BIOS options catered to a specific Parrot OS USB I had not formatted since using it as a bootable USB in said options menu, and after playing around with the boot options and reconfiguring the BIOS about +100 times I was able to finally boot up Parrot OS and got lucky the whole install procedure went fine.

However, if anyone else should not be so lucky, heres some quick info/the answer of my question Hopefully I save someone the headache as it was tragic experience coming across the explanation when it describes the bug not having been sorted out yet. I didnt find the fix until after I was able to luckily boot up Parrot.


Explanation as told by www.betanews.com:

"Ubuntu 17.10 corrupts the BIOS on some Lenovo, Toshiba and Acer laptops. ... The bug, which is labeled "critical" by the team behind Ubuntu, can cripple the BIOS on over 20 devices."


Solution proposed by dailylinuxuser.com:

http://dailylinuxuser.com/2018/01/how-to-fix-your-bios-after-installing-ubuntu-17-10-on-a-lenovo-laptop.html

May the force be w anyone else who becomes a temporary victim to this bug, as I thought I was stuck with Winblows 10 forever. You could have just shot me instead, Ubuntu 17.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.