2

I have a strange problem with Ubuntu. The space od my disk is eaten by system, probably. I have a disk separated into 3 areas - boot, exchange and free space for data. The sizes are 60GB, 16GB and 180GB. I feel the disk do not work fluency. The problem is connected with boot part - Normally I should have there 40GB of free space and after boot computer every day I have it, butafter few hours this space is smaller (currenlty 26GB of free space) and I do not know why. I dont install any programs, I just surf internet or use intellij - thats all. And free space is smaller. This is my output from df -h:

enter image description here

A you can see /dev/sda1 is the problem - it take more space all the time.

I have tried to do all thigs I know: clean, autoclean, clear logs and also used BleachBit - nothing helped. But after restart I have againa 40GB of free space which is reducing by the time I'm using system. What could be a source of this problem and how to repair it?

EDIT:

After installed ncdu, I got this info:

 8,9 GiB [##########] /var                                                                  
    4,2 GiB [####      ] /usr
  793,3 MiB [          ] /lib
  723,3 MiB [          ] /opt
  137,7 MiB [          ] /boot
   14,7 MiB [          ] /etc
   12,2 MiB [          ] /bin
   11,0 MiB [          ] /sbin
   88,0 KiB [          ] /tmp
   56,0 KiB [          ] /snap
   48,0 KiB [          ] /root
e  16,0 KiB [          ] /lost+found

Looks like var folder is too big. Go deeper:

5,8 GiB [##########] /gdm3                                                                 
    2,3 GiB [####      ] /snapd
  323,2 MiB [          ] /mongodb
  191,8 MiB [          ] /apt
   73,5 MiB [          ] /dpkg

Gdm3 is very big and its logs:

/var/lib/gdm3/.local/share/xorg 
                         /..                                                                   
    3,6 GiB [##########]  Xorg.0.log
    2,2 GiB [#####     ]  Xorg.0.log.old

How can I fix it?

  • 1
    Is the /tmp folder on your main partition? That one contains temporary data and is cleared during every boot, if it isn't mounted as RAM disk anyway. – Byte Commander Mar 23 '19 at 23:39
  • Yes, it is. How can I fix it? I ran sudo rm -r * in this folder, but it did not help. – allocer Mar 23 '19 at 23:40
  • 2
    Install and run ncdu. It is a command-line disk usage analyzer. I use it regularly. Use ncdu -x / and it will show you the usage of your / filesystem and we should be able to pin point what exactly uses up space. Likely some sort of caching or extensive logging is being done. – Sergiy Kolodyazhnyy Mar 24 '19 at 1:19
  • 3
    I would suggest running the second ncdu command in my previous comment after you have disk space eaten up, so that you can see where did it go. If you run that on a cleaned-up drive, obviously that won't tell you anything useful – Sergiy Kolodyazhnyy Mar 24 '19 at 1:22
  • 1
    It looks like your Xorg is filling up your logs, probably with an error. I've had this before. You can set the logs to limit their size as a short term fix; but you'll want to fix the problem causing the logs to fill up. This issue is a symptom of your Xorg problem. – pbhj Mar 30 '19 at 20:35
1

Looks like I found how to fix it. I edited custom.conf file in /etc/gdm3/custom.conf and comment line with #WaylandEnable=false. Now I do not have xor logs anymore and nothing "eat" space on disk.

|improve this answer|||||
  • 1
    Congrats on finding the workaround ! Xorg is the graphics or GUI and minimal logs for it are fine, but the amount of logging described in your question is definitely a concern. Along with this, I would recommend submitting a bug report on launchpad launchpad.net/gdm and saving some of the repeated errors that occur in the log. Chances are the developers should know about this – Sergiy Kolodyazhnyy Mar 30 '19 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.