0

I've had this issue plague me on and off on different Ubuntu distros over the years, and I don't understand how it was ever avoided (I thin I managed to rectify it before), and searching for answers comes up with nothing similar to this problem.

When I do an "svn commit" in my terminal (regular bash shell - local keyboard/monitor), rather than a prompt for my svn password immediately appearing in the terminal, the password prompt happens in a popup GUI window (Ubuntu 18.04 Gnome). I would like Ubuntu/subversion to STOP doing that and prompt directly in my terminal.

I do have the usual "store-passwords = no" and "store-plaintext-passwords = no" in my ~/.subversion/servers file, because that's how I like it. But it seems the "password getter" is handed over to the GUI, which creates the popup window, I cancel that, then the "password getter" is handed back to the terminal window, where the normal and expected prompt happens on the next terminal, line, but only because I cancelled the action from the GUI popup window. of course, had I not cancelled the "password getter" window and just entered my password in it and clicked "OK" it would work just fine. But I just don't want it to do that--if I am working in the terminal, then work should stay in the terminal, and the action of getting TEXT INPUT should not be handled by a GUI window (how dumb). (/rant)

Can anyone tell me how to disable the action of my subversion password being prompted for by a GUI window instead of directly in the terminal?

Thanks!

  • 2
    What do you mean exactly by "svn password"? are you connecting to the svn repo locally via plain svn, or via svn+ssh - or some other protocol? – steeldriver Mar 23 '19 at 11:38
  • I have a somewhat local apache and subversion server on my home network: sudo apt install subversion libapache2-mod-svn libapache2-svn libsvn-dev . .... then apache passwords created by: sudo htpasswd -cm /etc/apache2/dav_svn.passwd admin – rob_ee Mar 25 '19 at 11:16
  • (..... sigh .....) – rob_ee Mar 31 '19 at 12:16
1

Edit the ~/.subversion/config and uncomment the password-stores line as explained in the comments:

[auth]
### To disable all password stores, use an empty list:
password-stores =

the save it and try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.