0

Ubuntu 16.04, i5-Surface Pro-2.

Hi, I have an older Surface Pro-2 that dual boots Ubuntu and win8.1. It runs 24/7 almost entirely Ubuntu and always on mains power. This thing never sees the Internet so I have the Time Setting set to "Manual." But it gains or loses time, not just minutes but hours, but the date is always correct.

When I boot to windows it shows the current Ubuntu time.

How can I make this just stay with the current time after I set it?

  • wiki.archlinux.org/index.php/System_time#Time_skew there is also a section on ubuntu though admittedly I didn't read it. Also output of hwclock --show and timedatctl – j-money Mar 22 at 23:11
  • @j-money: Thanks for the reply. --show gives "correct Date/Time" + "0.452650 seconds". timedatectl shows correct stuff for Date/Times/Zones, but last line "RTC in local TZ = no." This would seem to be the issue as when I think about it, the error-time would probably be UTC time. Setting the TZ into the RTC might fix this. I will do some searching on how to do that. – LinuxFerLife Mar 23 at 18:11
  • @j-money: OK, found this (unix.stackexchange.com/questions/80382/…) and it has changed the RTC line to "yes" so will see how this goes over the next few days. Thanks again. – LinuxFerLife Mar 23 at 18:23
  • great! If it does end up working consider answering your question with your solution! – j-money Mar 23 at 18:27
  • @j-money It is looking good, just booted to win8.1 via Ubuntu Terminal and it has the correct time in win. Good start. But I also tried to change it on my laptop that does have Internet access and it seems that setting the RTC to "yes" needs to have the two preceding options for auto-setting via Internet set to to Off/No. I got a warning message on this laptop about not using RTC = yes. But I will confirm working/not working on the non-Internet Surface Pro in a few days. – LinuxFerLife Mar 23 at 18:45
0

This link seems to solve the issue.

https://unix.stackexchange.com/questions/80382/arch-time-zone-wrong-time-due-to-local-time-hardware-clock

Setting this

timedatectl set-local-rtc 1

but, you need to have already set the automatic Internet time to Manual, otherwise you will get a warning about the contradictions of doing this with Internet update turned on.

My PC in question has no Internet access so I had already set it to "Manual" but I suspect that nothing too bad would happen of you ignore the warning and left Auto turned on.

But, for me it was off and all is working fine when I boot to win8.1 I get the same correct time as Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.