0

So this is my first post to this site. I've looked around and cannot find any other posts that match the issue I'm having.

I recently updated my desktop (a HP Elite One 800 all in one) to Ubuntu 18.10. This has resulted in the computer not connecting to the internet over ethernet which worked fine before updating.

I've checked the ethernet cable on my Windows 10 laptop and can confirm the cable is fine as I've full connectivity over it, as does wireless over the laptop as well as my smart phone, tablet and Kindle plus ethernet connected Xbox One and Apple TV so the network itself seems fine.

When I check the settings a question mark is located over the network icon, but in the network settings page wired connection says "Conencted - 100Mb/s". Both IPv4 and IPv6 are set to "Automatic (DHCP)".

Would anyone know any solutions to getting my ethernet working again as I'm still quite new to Ubuntu? The computer does not have wireless options only ethernet.

Edits

sudo lshw -C network
*network
     description: Ethernet interface
     product: Ethernet Connection I217-LM
     vendor: intel Corporation
     physical id: 19
     bus info: pci@0000:00:19.0
     logical name: eno1
     version: 04
     serial: c8:cb:b8:2a:02:2f
     capacity: 1Gbit/s
     width: 32 bits
     clock: 33MHz
     capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
     configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.13-4 ip 192.168.1.4 latency=0 link=yes multicast=yes port=twist pair speed=100Mbit/s
     resources: irq:25 memory:f7c00000-f7c1ffff memory:f7c3d000-f7c3dfff ioport:f080(size=32)


ipconfig
     command 'ipconfig' not found, did you mean:
        command 'ifconfig" from deb net-tools
        command 'iwconfig' from deb wireless-tools
        command 'iconfig' from deb ipmiutil


cat/etc/netplan/*.yaaml
     #Let NetworkManager manage all devices on this system
     network:
        version: 2
        renderer: NetworkManager
  • Edit your question and show me sudo lshw -C network and ifconfig and cat /etc/netplan/*.yaml. Please describe your ethernet wiring from the computer, all the way to the router/modem. I strongly suspect either a cable problem, or a switch/hub/router/modem problem. Is this something that used to work, or it has never worked? Report back to @heynnema – heynnema Mar 22 at 20:55
  • updated ... to Ubuntu 18.10 from what? Was the network working before? – GabrielaGarcia Mar 22 at 20:57
  • I updated with the requested information. I'm not sure what my previous Ubuntu version was but I think it was the most recent version before 10.18. The network (and internet) functioned normally before the update. – Craig Kirkwood Mar 24 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.