0

I am trying to install Photoshop CS6 on my Ubuntu machine (dual-boot) with Windows OS.

Before proceeding with the steps, I researched here and found this link: Installing Photoshop on Ubuntu 18.04

I followed the steps listed in the answer, but my PlayOnLinux failed and gave me this error:

PlayOnLinux Error while installing Photoshop CS6

The installation was working fine, and even the missing Microsoft Fonts got installed automatically. But, this unexpected error aborted the installation completely.

Note: Before installing Photoshop CS6, I installed MS PAINT through Wine, and it got installed without any errors.

Also, note that when I visit Home >> PlayOnLinux's Virtual Drives folder, I can see the virtual drive created for Adobe Photoshop CS6. Here's the proof:

POL-Virtual-Drives

  • Have you tried starting it? I have seen this error a lot of times, but in most cases the application worked despite the error. – danzel Mar 22 at 18:30
  • I did, but I did not find it anywhere. I read on a thread that - even if I encounter such an error, I must wait for 5 minutes and then check. Instead of 5, I waited for 20minutes, but still, nothing changed. I searched for Adobe Photoshop in every possible location, but alas, failed. – Manu Mathur Mar 22 at 18:34
  • I don't see how waiting would help, but you can look in the Photoshop CS6 folder in your screenshot. There is probably a folder called drive_c, which contains the windows file system. I don't know where Photoshop installs, but probably Program Files. See if you can find the appropriate exe file there. In PlayOnLinux, you can "run a .exe in this virtual drive" and select it manually. Alternatively, you can "create a shortcut" from that drive in which case POL will look for .exe files for you. – danzel Mar 22 at 18:44
  • I can definitely find drive_c folder having Windows files, but there is no .exe file. I checked every folder two times. As far as waiting time is concerned, even I agree it doesn't make sense, but as it was written there, so I thought of giving it a try. – Manu Mathur Mar 22 at 18:54
  • At which step did the installation crash? I just tried it, the install script seems to be buggy. Adobe AIR is downloaded but the installer doesn't find it. Additionally, the .exe installer I found on Adobe's website was a self extracting archive, so I had to start the installer itself after extracting the archive using the "run a .exe in this virtual drive" functionality of POL. Since all prerequisites have been installed successfully, try to manually install it in the same virtual drive. I didn't get past the "register now" step in the installer so I couldn't test it. – danzel Mar 22 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.