3

I'm trying to install LPCXpresso v8.2.2 on my new Ubuntu 18.04 (amd64 of course) laptop. Following the read me I issue the command

sudo apt-get install libgtk2.0-0:i386 libxtst6:i386 libpangox 1.0-0:i386 \ libpangoxft-1.0-0:i386 libidn11:i386 libglu1-mesa:i386 \ libncurses5:i386 libudev1:i386 libusb-1.0:i386 libusb-0.1:i386 \ gtk2-engines-murrine:i386 libnss3-1d:i386

In order to install i386 compatible libraries. Here's the output

Building dependency tree Reading state information... Done Note, selecting 'libusb-1.0-0:i386' for regex 'libusb-1.0'

Note, selecting 'libusb-1.0-0-dev:i386' for regex 'libusb-1.0'

Note, selecting 'libusb-1.0-doc:i386' for regex 'libusb-1.0'

Note, selecting 'libusb-1.0-doc' instead of 'libusb-1.0-doc:i386'

Note, selecting 'libusb-0.1-4:i386' for regex 'libusb-0.1'

Package libnss3-1d:i386 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

When then I try to execute the installer with

sudo ./Installer_LPCXpresso_8.2.2_650_Linux-x86

Simply nothing happens. Has anyone already had similar issues?

2
  • Did you forgot to run sudo dpkg --add-architecture i386 followed by sudo apt update?
    – N0rbert
    Mar 22 '19 at 17:33
  • Thanks for the hint, I run that but i got same output for libnss3-1d
    – a_bet
    Mar 23 '19 at 18:16
0

From search on packages.ubuntu.com I see that libnss3-1d package is not available for Ubuntu 18.04 LTS.

It seems to be renamed to libnss3. Install 32-bit version of it with

sudo apt-get install libnss3:i386

and continue.


I'm not familiar with these tools, but you can also try MCUXpresso (plus see installation guide).

1
  • Thanks, now I was able to run the installer.
    – a_bet
    Mar 28 '19 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.