1

(Yes, this is a duplicate of an unanswered question. I tried to post on it, but my post was deleted, so I'm asking the same question, but my own way.)

I'm unable to add the LibreOffice repo. Here's what I did and the result:

steve@ubuntu:~$ sudo add-apt-repository ppa:libreoffice/ppa
Cannot add PPA: 'ppa:~libreoffice/ubuntu/ppa'.
ERROR: '~libreoffice' user or team does not exist.

My internet connection is fine, I have (and need) no proxy for internet access. Command like

sudo apt update sudo apt upgrade work fine and in fact, I run both every time I start up the system (largely because VSCode-insiders updates every day.)

Answers to the OP seem to indicate that the tilde in the PPA name is my problem, but I AM NOT ENTERING A TILDE! It seems that apt-get-repository is adding it for me. I have not found anyone else having this issue adding the LibreOffice PPA, so it must be my fault, but I have no idea what I could have done to cause this. In fact, this is the first time I have ever even tried to use apt-add-repository.

Help? Please?

1

If you copied the said command from somewhere it's possible that unseen symbols are being copied too. What I suggest:

  1. try manually typing the whole command
  2. add PPA via GUI (In the “Software & Updates” or “Software Sources”)
  3. Install LibreOffice via snap or deb package

EDIT:

Whether options mentioned above do not work for you simply add this to your sources.list:

deb http://ppa.launchpad.net/libreoffice/libreoffice-6-1/ubuntu bionic main 
deb-src http://ppa.launchpad.net/libreoffice/libreoffice-6-1/ubuntu bionic main 

and execute sudo apt update. When the update procedure finishes proceed with the installation as you do for any package:

sudo apt install package_name

Hope that helps.

  • Thanks for the manual steps, I searched for that yesterday but apparently I couldn't guess the correct search terms. But, I did paste from a web page... directly into Notepad++ which was set to reveal all unprintables because I am paranoid. It looked exactly the same in Notepad++, so I entered it. Really strange that a NETWORK ISSUE can change the name of the ppa and complain about that instead of the REAL ISSUE. However, it decided to work today, so I am sorry to have bothered everyone, but I think your answer will help others. Thanks again! – Steve Valliere Mar 22 at 15:47
0

The command to add PPA is completely correct (equals to sudo add-apt-repository ppa:libreoffice/ppa shown on LibreOffice PPA page).
I have seen the

Cannot add PPA: 'ppa:~libreoffice/ubuntu/ppa'.
ERROR: '~libreoffice' user or team does not exist.

message sometimes, but for me it seems to be networking issue as it works after some time.

So have to wait some time and try again. Or try to download using other ISP (for example cellular Wi-Fi hotspot).

  • Our office only has one form of internet access for our desktops (through Spectrum business internet). After trying several times across the previous two days though, it worked fine today. Sorry to be a bother. – Steve Valliere Mar 22 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.