1

I've just installed Ubuntu on my desktop, and I've installed the nVidia drivers by using the ubuntu-drivers command. When I plug the HDMI cable on the GPU slot, though, the desktop image becomes larger than my TV. Here is an image. The selected resolution is 4096 x 2160, the same resolution that works perfectly when the HDMI is plugged on the motherboard. The output of xrandr -q is:

v@v:~$ xrandr -q
Screen 0: minimum 8 x 8, current 4096 x 2160, maximum 32767 x 32767
HDMI-0 connected primary 4096x2160+0+0 (normal left inverted right x axis y axis) 256mm x 135mm
   3840x2160     60.00 +  59.94    50.00    29.97    25.00    23.98  
   4096x2160     59.94*   50.00    29.97    25.00    24.00    23.98  
   1920x1080    119.88   100.00    60.00    59.94    50.00    29.97    25.00    23.98  
   1360x768      60.02  
   1280x1024     60.02  
   1280x720      59.94    50.00  
   1152x864      60.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.95    59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
USB-C-0 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-2 disconnected (normal left inverted right x axis y axis)
DP-1-1 disconnected (normal left inverted right x axis y axis)

The same problem persists when changing the resolution to 3840x2160. My TV is properly adjusted for a 16:9 ratio. How do I fix this problem?

1

Your TV is overscanning. Unfortunately this is the default setting in most brands, to account for cheap boxes from cable TV providers.

Solution:

ALWAYS set Ubuntu for the TVs native resolution and then change the mode in the TV itself. The settings is either in the settings menu, in a dedicated key in the remote control or both. Check your user's manual.

1
  • Happened to me on Samsung SyncMaster P2450 monitor as well... – betatester07 Jul 19 '19 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.