2

Can't install. Can't uninstall. System updates now do not work. How do I fix this?

It started with apt install libreoffice and it failed.

apt --fix-broken-install fails as follows:

sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libreoffice-common
The following NEW packages will be installed:
  libreoffice-common
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
74 not fully installed or removed.
Need to get 0 B/24.7 MB of archives.
After this operation, 79.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
(Reading database ... 406426 files and directories currently installed.)
Preparing to unpack .../libreoffice-common_1%3a6.0.7-0ubuntu0.18.04.2_all.deb ...
Unpacking libreoffice-common (1:6.0.7-0ubuntu0.18.04.2) ...
dpkg: error processing archive /var/cache/apt/archives/libreoffice-common_1%3a6.0.7-0ubuntu0.18.04.2_all.deb (--unpack):
 trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.1.3-9783
rmdir: failed to remove '/var/lib/libreoffice/share/prereg/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/share/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/program/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a6.0.7-0ubuntu0.18.04.2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Adding more info to original question as requested:

$ sudo apt autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1:6.0.7) but it is not installed
 libreoffice-java-common : Depends: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2) but it is not installed
 libreoffice-ogltrans : Depends: libreoffice-common but it is not installed
 libreoffice-report-builder : Depends: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2) but it is not installed
 libreoffice-script-provider-bsh : Depends: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2) but it is not installed
 libreoffice-script-provider-js : Depends: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2) but it is not installed
 libreoffice-script-provider-python : Depends: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2) but it is not installed
 libreoffice-style-galaxy : Depends: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2) but it is not installed
 libreoffice-style-tango : Depends: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
$ sudo dpkg --configure -a
[sudo] password for jax: 
Setting up libboost-date-time1.65.1:amd64 (1.65.1+dfsg-0ubuntu5) ...
dpkg: dependency problems prevent configuration of libreoffice-ogltrans:
 libreoffice-ogltrans depends on libreoffice-common; however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-ogltrans (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-style-galaxy:
 libreoffice-style-galaxy depends on libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-style-galaxy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-script-provider-js:
 libreoffice-script-provider-js depends on libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-script-provider-js (--configure):
 dependency problems - leaving unconfigured
Setting up libraptor2-0:amd64 (2.0.14-1build1) ...
Setting up lp-solve (5.5.0.15-4build1) ...
dpkg: dependency problems prevent configuration of libreoffice-java-common:
 libreoffice-java-common depends on libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-java-common (--configure):
 dependency problems - leaving unconfigured
Setting up libcmis-0.5-5v5 (0.5.1+git20160603-3build2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
dpkg: dependency problems prevent configuration of libreoffice-script-provider-python:
 libreoffice-script-provider-python depends on libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-script-provider-python (--configure):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Setting up fonts-linuxlibertine (5.3.0-4) ...
dpkg: dependency problems prevent configuration of libreoffice-librelogo:
 libreoffice-librelogo depends on libreoffice-script-provider-python; however:
  Package libreoffice-script-provider-python is not configured yet.

dpkg: error processing package libreoffice-librelogo (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-wiki-publisher:
 libreoffice-wiki-publisher depends on libreoffice-java-common; however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice-wiki-publisher (--configure):
 dependency problems - leaving unconfigured
Setting up fonts-liberation2 (2.00.1-7~18.04.1) ...
dpkg: dependency problems prevent configuration of libreoffice-sdbc-hsqldb:
 libreoffice-sdbc-hsqldb depends on libreoffice-java-common (>= 1:6.0.7~); however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice-sdbc-hsqldb (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-core:
 libreoffice-core depends on libreoffice-common (>> 1:6.0.7); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-calc:
 libreoffice-calc depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-calc (--configure):
 dependency problems - leaving unconfigured
Setting up fonts-crosextra-carlito (20130920-1) ...
Setting up libclucene-core1v5:amd64 (2.3.3.4+dfsg-1) ...
Setting up librevenge-0.0-0:amd64 (0.0.4-6ubuntu2) ...
Setting up libmhash2:amd64 (0.9.9.9-7) ...
Setting up libneon27-gnutls:amd64 (0.30.2-2build1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Setting up libxmlsec1:amd64 (1.2.25-1build1) ...
Setting up libclucene-contribs1v5:amd64 (2.3.3.4+dfsg-1) ...
Setting up fonts-crosextra-caladea (20130214-2) ...
dpkg: dependency problems prevent configuration of python3-uno:
 python3-uno depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package python3-uno (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libabw-0.1-1:amd64 (0.1.2-1ubuntu1) ...
dpkg: dependency problems prevent configuration of libreoffice-base-drivers:
 libreoffice-base-drivers depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-base-drivers (--configure):
 dependency problems - leaving unconfigured
Setting up librasqal3:amd64 (0.9.32-1build1) ...
Setting up libeot0:amd64 (0.01-5) ...
Setting up libexttextcat-data (3.4.5-1) ...
Setting up libmythes-1.2-0:amd64 (2:1.2.4-3) ...
Setting up libcdr-0.1-1:amd64 (0.1.4-1build1) ...
dpkg: dependency problems prevent configuration of libreoffice-style-tango:
 libreoffice-style-tango depends on libreoffice-style-galaxy; however:
  Package libreoffice-style-galaxy is not configured yet.
 libreoffice-style-tango depends on libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-style-tango (--configure):
 dependency problems - leaving unconfigured
Setting up libhsqldb1.8.0-java (1.8.0.10+dfsg-8) ...
Setting up liblangtag-common (0.6.2-1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for shared-mime-info (1.9-2) ...
dpkg: dependency problems prevent configuration of libreoffice-report-builder:
 libreoffice-report-builder depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.
 libreoffice-report-builder depends on libreoffice-java-common; however:
  Package libreoffice-java-common is not configured yet.
 libreoffice-report-builder depends on libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-report-builder (--configure):
 dependency problems - leaving unconfigured
Setting up libwps-0.4-4:amd64 (0.4.8-1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
dpkg: dependency problems prevent configuration of libreoffice-gtk3:
 libreoffice-gtk3 depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-gtk3 (--configure):
 dependency problems - leaving unconfigured
Setting up librdf0:amd64 (1.0.17-1.1) ...
dpkg: dependency problems prevent configuration of libreoffice-script-provider-bsh:
 libreoffice-script-provider-bsh depends on libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-common is not installed.
 libreoffice-script-provider-bsh depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.
 libreoffice-script-provider-bsh depends on libreoffice-java-common; however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice-script-provider-bsh (--configure):
 dependency problems - leaving unconfigured
Setting up libbsh-java (2.0b4-19) ...
Setting up fonts-opensymbol (2:102.10+LibO6.0.7-0ubuntu0.18.04.2) ...
Setting up fonts-sil-gentium (20081126:1.03-2) ...
Setting up uno-libs3 (6.0.7-0ubuntu0.18.04.2) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Setting up fonts-sil-gentium-basic (1.102-1) ...
Setting up liborcus-0.13-0:amd64 (0.13.4-2) ...
Setting up libxmlsec1-nss:amd64 (1.2.25-1build1) ...
dpkg: dependency problems prevent configuration of libreoffice-gnome:
 libreoffice-gnome depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.
 libreoffice-gnome depends on libreoffice-gtk3; however:
  Package libreoffice-gtk3 is not configured yet.

dpkg: error processing package libreoffice-gnome (--configure):
 dependency problems - leaving unconfigured
Setting up libgpgmepp6:amd64 (1.10.0-1ubuntu2) ...
Processing triggers for fontconfig (2.12.6-0ubuntu2) ...
Setting up libfreehand-0.1-1 (0.1.2-2) ...
dpkg: dependency problems prevent configuration of libreoffice-nlpsolver:
 libreoffice-nlpsolver depends on libreoffice-calc; however:
  Package libreoffice-calc is not configured yet.
 libreoffice-nlpsolver depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.
 libreoffice-nlpsolver depends on libreoffice-java-common; however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice-nlpsolver (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-draw:
 libreoffice-draw depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-draw (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-avmedia-backend-gstreamer:
 libreoffice-avmedia-backend-gstreamer depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-avmedia-backend-gstreamer (--configure):
 dependency problems - leaving unconfigured
Setting up libmwaw-0.3-3:amd64 (0.3.13-1) ...
dpkg: dependency problems prevent configuration of libreoffice-writer:
 libreoffice-writer depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-writer (--configure):
 dependency problems - leaving unconfigured
Setting up liblangtag1:amd64 (0.6.2-1) ...
dpkg: dependency problems prevent configuration of libreoffice-impress:
 libreoffice-impress depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.
 libreoffice-impress depends on libreoffice-draw (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-draw is not configured yet.

dpkg: error processing package libreoffice-impress (--configure):
 dependency problems - leaving unconfigured
Setting up libepubgen-0.1-1:amd64 (0.1.0-2ubuntu1) ...
Setting up libodfgen-0.1-1:amd64 (0.1.6-2) ...
Setting up libvisio-0.1-1:amd64 (0.1.6-1build1) ...
Setting up libmspub-0.1-1:amd64 (0.1.4-1) ...
Setting up libexttextcat-2.0-0:amd64 (3.4.5-1) ...
dpkg: dependency problems prevent configuration of libreoffice-base:
 libreoffice-base depends on libreoffice-base-drivers (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-base-drivers is not configured yet.
 libreoffice-base depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-base (--configure):
 dependency problems - leaving unconfigured
Setting up libwpd-0.10-10:amd64 (0.10.2-2) ...
dpkg: dependency problems prevent configuration of libreoffice-math:
 libreoffice-math depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-math (--configure):
 dependency problems - leaving unconfigured
Setting up libe-book-0.1-1:amd64 (0.1.3-1) ...
dpkg: dependency problems prevent configuration of libreoffice:
 libreoffice depends on libreoffice-base; however:
  Package libreoffice-base is not configured yet.
 libreoffice depends on libreoffice-calc; however:
  Package libreoffice-calc is not configured yet.
 libreoffice depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.
 libreoffice depends on libreoffice-draw; however:
  Package libreoffice-draw is not configured yet.
 libreoffice depends on libreoffice-impress; however:
  Package libreoffice-impress is not configured yet.
 libreoffice depends on libreoffice-math; however:
  Package libreoffice-math is not configured yet.
 libreoffice depends on libreoffice-writer; however:
  Package libreoffice-writer is not configured yet.
 libreoffice depends on libreoffice-avmedia-backend-gstreamer; however:
  Package libreoffice-avmedia-backend-gstreamer is not configured yet.
 libreoffice depends on python3-uno (>= 4.4.0~beta2); however:
  Package python3-uno is not configured yet.

dpkg: error processing package libreoffice (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-sdbc-postgresql:
 libreoffice-sdbc-postgresql depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-sdbc-postgresql (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-report-builder-bin:
 libreoffice-report-builder-bin depends on libreoffice-base; however:
  Package libreoffice-base is not configured yet.
 libreoffice-report-builder-bin depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-report-builder-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-base-core:
 libreoffice-base-core depends on libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-base-core (--configure):
 dependency problems - leaving unconfigured
Setting up libpagemaker-0.0-0:amd64 (0.0.4-1) ...
Setting up libetonyek-0.1-1:amd64 (0.1.7-3) ...
Setting up libwpg-0.3-3:amd64 (0.3.1-3) ...
Setting up ure (6.0.7-0ubuntu0.18.04.2) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Errors were encountered while processing:
 libreoffice-ogltrans
 libreoffice-style-galaxy
 libreoffice-script-provider-js
 libreoffice-java-common
 libreoffice-script-provider-python
 libreoffice-librelogo
 libreoffice-wiki-publisher
 libreoffice-sdbc-hsqldb
 libreoffice-core
 libreoffice-calc
 python3-uno
 libreoffice-base-drivers
 libreoffice-style-tango
 libreoffice-report-builder
 libreoffice-gtk3
 libreoffice-script-provider-bsh
 libreoffice-gnome
 libreoffice-nlpsolver
 libreoffice-draw
 libreoffice-avmedia-backend-gstreamer
 libreoffice-writer
 libreoffice-impress
 libreoffice-base
 libreoffice-math
 libreoffice
 libreoffice-sdbc-postgresql
 libreoffice-report-builder-bin
 libreoffice-base-core
sudo apt autoclean
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Del libvirt-daemon 4.0.0-1ubuntu8.7 [2,175 kB]
Del pgadmin4-common 4.2-1.pgdg18.04+1 [2,634 kB]
Del libnvidia-gl-390 390.77-0ubuntu0.18.04.2 [14.3 MB]
Del libnvidia-common-390 390.77-0ubuntu0.18.04.2 [11.4 kB]
Del nvidia-driver-390 390.77-0ubuntu0.18.04.2 [379 kB]
Del libgs9 9.26~dfsg+0-0ubuntu0.18.04.5 [2,264 kB]
Del nvidia-compute-utils-390 390.77-0ubuntu0.18.04.2 [66.6 kB]
Del libnvidia-compute-390 390.77-0ubuntu0.18.04.2 [21.0 MB]
Del libnvidia-decode-390 390.77-0ubuntu0.18.04.2 [1,186 kB]
Del libvirt-daemon-driver-storage-rbd 4.0.0-1ubuntu8.7 [15.4 kB]
Del ghostscript-x 9.26~dfsg+0-0ubuntu0.18.04.5 [42.9 kB]
Del nvidia-kernel-source-390 390.77-0ubuntu0.18.04.2 [8,443 kB]
Del libnvidia-compute-390 390.77-0ubuntu0.18.04.2 [20.6 MB]
Del libvirt-clients 4.0.0-1ubuntu8.7 [595 kB]
Del libnvidia-encode-390 390.77-0ubuntu0.18.04.2 [50.5 kB]
Del libnvidia-encode-390 390.77-0ubuntu0.18.04.2 [50.2 kB]
Del ghostscript 9.26~dfsg+0-0ubuntu0.18.04.5 [51.3 kB]
Del libnvidia-fbc1-390 390.77-0ubuntu0.18.04.2 [42.6 kB]
Del libvirt-daemon-system 4.0.0-1ubuntu8.7 [80.7 kB]
Del nvidia-kernel-common-390 390.77-0ubuntu0.18.04.2 [11.6 kB]
Del libnvidia-ifr1-390 390.77-0ubuntu0.18.04.2 [66.7 kB]
Del libnvidia-decode-390 390.77-0ubuntu0.18.04.2 [1,117 kB]
Del libgs9-common 9.26~dfsg+0-0ubuntu0.18.04.5 [5,092 kB]
Del pgadmin4 4.2-1.pgdg18.04+1 [270 kB]
Del libnvidia-gl-390 390.77-0ubuntu0.18.04.2 [14.9 MB]
Del xserver-xorg-video-nvidia-390 390.77-0ubuntu0.18.04.2 [1,614 kB]
Del libnvidia-ifr1-390 390.77-0ubuntu0.18.04.2 [59.8 kB]
Del libvirt0 4.0.0-1ubuntu8.7 [1,248 kB]
Del libnvidia-cfg1-390 390.77-0ubuntu0.18.04.2 [71.2 kB]
Del libnvidia-fbc1-390 390.77-0ubuntu0.18.04.2 [39.8 kB]
Del nvidia-utils-390 390.77-0ubuntu0.18.04.2 [324 kB]
Del nvidia-dkms-390 390.77-0ubuntu0.18.04.2 [24.2 kB]
$ sudo apt update
Get:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Hit:2 http://apt.postgresql.org/pub/repos/apt bionic-pgdg InRelease                                                          
Hit:3 http://us.archive.ubuntu.com/ubuntu bionic InRelease                                                                         
Get:4 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]                                                     
Get:6 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]                                          
Hit:5 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease             
Get:7 http://us.archive.ubuntu.com/ubuntu bionic-backports/main amd64 Packages [1,024 B]
Get:8 http://us.archive.ubuntu.com/ubuntu bionic-backports/main i386 Packages [1,024 B]
Get:9 http://us.archive.ubuntu.com/ubuntu bionic-backports/main Translation-en [448 B]
Get:10 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [557 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [476 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [734 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [744 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 Packages [6,424 B]
Get:15 http://us.archive.ubuntu.com/ubuntu bionic-updates/multiverse i386 Packages [6,580 B]
Fetched 2,778 kB in 2s (1,288 kB/s)                            
Reading package lists... Done
Building dependency tree       
Reading state information... Done
6 packages can be upgraded. Run 'apt list --upgradable' to see them.
17
  • 1
    hello! could you try sudo dpkg --configure -a && sudo apt autoremove && sudo apt autoclean && sudo apt update and add the output of all that to your question please?
    – tatsu
    Mar 21, 2019 at 14:32
  • 1
    Oops, can't add the output, over the character limit. But it failed "unmet dependencies." ... off with dog, brb
    – Jack Woehr
    Mar 21, 2019 at 15:17
  • 1
    if you mean as in "the process is still running with no end in sight" in that case yes. if you mean "I was in the middle of figuring out what to do to remove it" then please continue first.
    – tatsu
    Mar 21, 2019 at 16:37
  • 1
    not the whole list I hope :D ? just those that concern libre and open office?
    – tatsu
    Mar 21, 2019 at 16:39
  • 1
    Ha! Just libreoffice* ... and THAT WORKED!!!
    – Jack Woehr
    Mar 21, 2019 at 16:47

2 Answers 2

5

sudo dpkg -r every single libreoffice package which apt list showed as installed. Tedious, as one has to wander around in dependency order, but it worked. apt is once again sane. Thanks @tatsu for help!!!

1
  • dpkg -r `apt list --installed libreoffice* |egrep -o '^[^/]+'` However even with that command (which at a minimum should be in your answer), I still got errors downstream of: python3-uno depends on libreoffice-common (>= 1:7.0.0~alpha~) So then it is time for: apt --fix-broken install After which: apt-get dist-upgrade shows only packages no longer required. So: apt autoremove And finally Ubuntu's "Software Updater" GUI app succeeds. Nov 16, 2020 at 15:18
1

If you have Sophos Antivirus running on your system it can be a reason for this problem

in this case first stop sophos

//find service name
systemctl list-units | grep sav 
//stop the service
sudo systemctl stop sav-protect.service

now you can run install

sudo apt-get -f install

start sophos again

sudo systemctl start sav-protect.service
1
  • Had a similar issue and this fixed the problem. Thank you!
    – Superspork
    Jan 19, 2020 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.