so I am trying to change my icons for specific applications.

In my case I changed the chromium icon to a custom one. I copied the chromium.desktop from the snap directory to ~/.local/share/applications changed the icon entry to my path icon path. The icon in the application menu appears and it works, but the old icon persists also which is not that bad because I don't use the application menu.

The thing is now when I click my new icon chromium opens, but with the old icon. Meaning the old icon and the new icon are now in my dock. (btw the same for vscode)

What am I missing?


I am using gnome with ubuntu 18.04

1 Answer 1


Seems like I found the right folder. Snaps have their own desktop directory.


Changed the icon their et voila everything works fine.

Still not very clear for me why the .local hasn't overwritten the old entry, or why it starts the "old" application but okay fine by me.

  • Indeed, I would also expect that .local/share/applications would also override the .desktop files in the snap directories. Did it also not work after logging out and back in?
    – vanadium
    Commented Mar 22, 2019 at 11:23
  • I haven't tryied to relog also I am not using wayland. But I also havn't restarted it, but it works now, so I don't bother anymore with it.
    – Dimfred
    Commented Mar 22, 2019 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .