0

I've just installed Ubuntu on a Dell XPS 9570 but now can't access it after rebooting.

In the first place, the installation program couldn't detect any hard drive so I changed the SATA parameter (previously on RAID) to AHCI. This solved the detection problem, I installed Ubuntu and it seemed to work fine.

The problem is that after rebooting, Windows 10 wouldn't load : I changed the SATA parameter back to RAID and now Windows works fine.

But now, if I reboot to get back to Ubuntu, I get the following screen : ACPI Exception / ACPI Error / CPU temperature above threshold How can I access Ubuntu, while still having access to Windows ?

Best, Lucas

  • Welcome. Which versions of Ubuntu/Windows are you using? – Minty Mar 21 at 14:59
0

This should fix your problem with RAID vs AHCI...

Some folks have found the 2nd choice that I provide easier to do...

Make sure to have a backup of your important Windows files!

You've got a single SSD set up in RAID mode, and the Ubuntu installer won't recognize your SSD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot.

Choice #1: Looking at this article https://samnicholls.net/2016/01/14/how-to-switch-sata-raid-to-ahci-windows-10-xps-13/ will show you how to make the change without having to reinstall Windows.

  • Boot to Windows with your current SATA controller configuration
  • Open Device Manager
  • Expand Storage Controllers and identify the Intel SATA RAID Controller
  • View properties of the identified controller
  • On the Driver tab, click the Update driver… button
  • Browse my computer…, Let me pick…
  • Uncheck Show compatible hardware
  • Select Microsoft as manufacturer
  • Select Microsoft Storage Spaces Controller as model
  • Accept that Windows cannot confirm that this driver is compatible
  • Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
  • Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

Choice #2: See http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

  • Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  • If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:
  • Click the Start Button and type cmd
  • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  • If this command does not work for you, try bcdedit /set safeboot minimal
  • Restart the computer and enter BIOS Setup (the key to press varies between systems).
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  • If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.
  • Hello heynnema, and thanks a lot for helping out. Choice #1: didn't work as I wasn't able to log in either Windows or Ubuntu at the end, had to restore the whole system to be able to get back to Windows. Choice #2: seems to work fine for the moment, as I just checked in to Windows after trying out Ubuntu. – Lucas Piquet Mar 23 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.