0

Existing OS is Windows 10 installed on SSD. When I tried to install Ubuntu, the only partition available is HDD. I don't see SSD at all. So, I have no choice but to install Ubuntu on HDD.

nvme0n1 = Windows 10, sda = Ubuntu

The following lsblk and df -h taken after installation of both OS. I'll reproduce the issue in VM and will share the screenshot later.

lsblk

user@ubuntu:~$ lsblk 
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda           8:0    0 931.5G  0 disk 
├─sda1        8:1    0    16M  0 part 
├─sda2        8:2    0 187.1G  0 part 
├─sda3        8:3    0   513M  0 part 
└─sda4        8:4    0 743.9G  0 part /
nvme0n1     259:0    0   477G  0 disk 
├─nvme0n1p1 259:1    0   499M  0 part 
├─nvme0n1p2 259:2    0    99M  0 part /boot/efi
├─nvme0n1p3 259:3    0    16M  0 part 
└─nvme0n1p4 259:4    0 476.3G  0 part 
user@ubuntu:~$ 

df -h

user@ubuntu:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            7.8G     0  7.8G   0% /dev
tmpfs           1.6G  2.1M  1.6G   1% /run
/dev/sda4       732G  7.8G  687G   2% /
tmpfs           7.8G   40M  7.8G   1% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           7.8G     0  7.8G   0% /sys/fs/cgroup
/dev/nvme0n1p2   95M   31M   65M  33% /boot/efi
tmpfs           1.6G   16K  1.6G   1% /run/user/121
tmpfs           1.6G   32K  1.6G   1% /run/user/1000
/dev/sda2       188G  3.2G  184G   2% /media/user/New Volume
user@ubuntu:~$ 

Would it be possible to install both OS in SSD, and not HDD?

  • Make sure Windows is not hibernated. – Melebius Mar 21 at 12:25
  • 1
    I guess Windows is installed on nvme0n1p4. There is no room on this disk to install ubuntu on. You need to shrink the windows partition. – Carl Mar 21 at 12:33
  • 1
    Many systems need UEFI update and SSD firmware update. – oldfred Mar 21 at 13:25
  • @Carl, how do you know windows is installed on nvme0n1p4? Btw, Partition Magic can be used to shrink windows partition right? No wonder I don't see it at all during installation ... It's been fully utilized by windows – Sabrina Mar 22 at 9:36
  • 1
    @Sabrina did you find the disk set to RAID in your BIOS? Is the disk ENABLED in your BIOS? Does gparted see the disk? – heynnema Mar 25 at 13:23
2

You don't need to reinstall Windows...

Some folks have found the 2nd choice that I provide easier to do...

Make sure to have a backup of your important Windows files!

You've got a single SSD set up in RAID mode, and the Ubuntu installer won't recognize your SSD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot.

Choice #1: Looking at this article https://samnicholls.net/2016/01/14/how-to-switch-sata-raid-to-ahci-windows-10-xps-13/ will show you how to make the change without having to reinstall Windows.

  • Boot to Windows with your current SATA controller configuration
  • Open Device Manager
  • Expand Storage Controllers and identify the Intel SATA RAID Controller
  • View properties of the identified controller
  • On the Driver tab, click the Update driver… button
  • Browse my computer…, Let me pick…
  • Uncheck Show compatible hardware
  • Select Microsoft as manufacturer
  • Select Microsoft Storage Spaces Controller as model
  • Accept that Windows cannot confirm that this driver is compatible
  • Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
  • Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

Choice #2: See http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

  • Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  • If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:
  • Click the Start Button and type cmd
  • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  • If this command does not work for you, try bcdedit /set safeboot minimal
  • Restart the computer and enter BIOS Setup (the key to press varies between systems).
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  • If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.
  • 2
    @Melebius learning is always a good thing :-) Whenever I see that a Ubuntu installer won't see the user's primary target disk, it's almost always that the disk is set as RAID in the BIOS. Now, there could be other things... like the SSD being used as a primary cache for the HDD... or SSD firmware needs an update... or the BIOS needs an update... a partitioning problem... or maybe even a hibernation problem... but RAID is usually the problem, and it only takes a second to check the BIOS setting. – heynnema Mar 22 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.