4

After going through all related questions (dozens of them), I still couldn't figure out.

system & hardware spec:

Lenovo Thinkpad P51, NVIDIA Quadro M2200 and Integrated Intel Graphic (hybrid graphic card),

Ubuntu 18.04 (dual boot with Win10)

symptom: When connected external monitor with HDMI port, no monitor detected.

  • xrandr outputs:
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080     60.02*+  60.01    59.97    59.96    59.93    48.00  
   1680x1050     59.95    59.88  

  • lspci |grep HDMI outputs nothing, lspci |grep VGA gives the following:
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
  • prime-select query gives intel (used to be nvidia, but when installing bumblebee and avoid the infamous login loop, I switched to Intel.
  • Nvidia Driver: nvidia-driver-410 with packages like nvidia-410 installed.

additional note: This worked before and still work on Win10 (dual boot), thus shouldn't be a hardware problem, but rather a config or hardware config one in the Ubuntu 18.04 system.

Thanks!

2
  • Same laptop here with the same issue, did you find a solution?
    – rzan
    Jul 12, 2019 at 10:32
  • @rzan unfortunately, I don't know the solution yet.
    – Alex Xiong
    Jul 14, 2019 at 2:24

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.