0

I'm using Ubuntu 18.04.2 LTS downloaded from Microsoft store and Arduino IDE. I'm trying to use ESP32 in Ubuntu, but Ubuntu can't find the serial port.

In Arduino, Tools > Port is greyed out. In Windows, I can see ESP32(COM7) and it works.

lsusb outputs nothing.
dmesg only outputs [0.009121] Microsoft 4.4.0-17763.379-Microsoft 4.4.35.

I tried:

  • kernel update
  • add the user to dialout
  • install cp210x driver
1
  • Low level I/O stuff that needs kernel functionality do generally not work with WSL. Think your serial ports belongs to this category. – Bengt Olsson Mar 24 '19 at 11:43
0

I face same issue. but finally connected.

ESP32 in ubuntu don't connect default

sudo apt-get install git wget libncurses-dev flex bison gperf python python-pip python-setuptools python-serial python-click python-cryptography python-future python-pyparsing python-pyelftools cmake ninja-build ccache libffi-dev libssl-dev

after this connect /dev/ttyUSB0 worked :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.