1

I installed Ubuntu Mate 18.10 on a 2008 Macbook (2.4 GHz). It's dual-booting with MacOS 10.6.8, using rEFInd.

On the very first boot of a standard installation, the top menu was empty. I have been unable to restore it.

I was able to get the installation working by switching to lightdm, but this provides a very minimal window manager. I'd prefer to have the full window environment I'm used to with Ubuntu Mate.

I've found various similar issues on various forums, and tried many suggestions, to no avail; I removed the .config directory, for instance.

Any suggestions how to get the menu back?

  • 1
    I'm not the only one putting Ubuntu on 2006-8 MacBooks then, neat! I usually stick with 14.04 32-bit Ubuntu, since it runs the fastest on the hardware in my experience. – Brenden McFarling Mar 29 at 0:13
  • Glad to hear such a suggestion! Hmm, too old for security updates. I was unsure about 32 vs. 64 bit. How much memory do you have? Is there a memory or processor speed threshold where you'd be inclined to use a 64 bit version, or do you advise 32 bit across the board for these? FWIW, I was doing this on a 2008 "Penryn" Macbook (2.4 GHz, currently 2GB RAM but I believe I have chips to upgrade it to 4GB.) I'm also considering putting Linux on a 2009 Macbook Pro, which is 2.53 GHz with 4 GB. (It can't run MacOS more recent than 10.11, and I've heard 10.11 is miserably slow on it without a SSD.) – Pete Forsyth Mar 29 at 6:30
  • Firstly, any version of OS X past about Mavericks is miserable without SSD in my eyes, so SSD is definite must for macOS/OS X 10.10+. I have 2.5 GB RAM and 4 GB RAM in a few machines, they each run 32-bit because I didn't feel like playing with rEFInd or something like that and Apple loved programming their machines to only boot 32-bit OSes, otherwise 64-bit is fine. 16.04 should work OK with better resources, maybe an SSD too. 64-bit is possible if you use something like rEFInd. (Fun fact, one of my '08s runs Mountain Lion just fine, which is past supposed support and is 64-bit... lol). – Brenden McFarling Mar 30 at 0:27
1

Things to try:

  • It is possible, that Ubuntu has detected two screens on your laptop (internal LVDS and external by HDMI), you can check it by changing the settings on monitors:

    1. Login to the MATE desktop from LightDM or other greeter.
    2. Open MATE terminal with Ctrl+Alt+T.
    3. If terminal is invisible - move it to the active screen by pressing Alt+F7 and moving mouse to the right or to the left to have terminal window on screen.
    4. From this terminal execute mate-display-properties and ensure, that current screen is set to Primary:

      Monitor Preferences

      switch other possible monitors to Off and click Apply.

    5. Check that MATE Panel is displayed on laptop screen.
  • If Monitor Preferences are OK, then try to relaunch MATE panel from terminal with:

    killall mate-panel
    mate-panel --replace &
    
  • Other possibility is to reset settings of MATE Panel to default

    dconf reset -f /org/mate/panel/
    mate-panel --replace &
    

Please check these methods and comment if it fails for you.

  • Well, I don't think that was it...the "monitor preferences" window only shows the one display (the laptop's built-in display). When I enter the "killall" command, the (empty) black bar at the top of the screen disappears, and with the "mate-panel" command it comes back. I get several "theme parsing errors" in the terminal, indicating that "gtk-widgets.css.3135.13: 'max-width' is not a valid property name" and "gtk-widgets.css.3136.14: 'max-height' is not a valid property name" – Pete Forsyth Mar 20 at 18:56
  • Also, the "mate-panel --replace &" command does not complete. It gives four of the errors like I described (#3 is identical to #1, and #4 is identical to #2), and then "hangs". I have to press control-C to get back to a command prompt. – Pete Forsyth Mar 20 at 18:58
  • These 4 warnings are normal, but the panel should be shown after then. What video card do you have? And which video driver do you use? – N0rbert Mar 20 at 20:34
  • It is a stock 2008 Macbook (Penryn): everymac.com/systems/apple/macbook_pro/specs/… So, I suppose that means it's this card: GeForce 8600M GT I did not explicitly choose any particular driver upon installation, but looking at the "proprietary drivers" window, it does not appear that it's using anything proprietary for the video card. (It IS using a proprietary driver for the Broadcom wireless card.) – Pete Forsyth Mar 20 at 20:48
  • (For what it's worth, I've just now installed lubuntu-desktop, which is working fine; and I think I may be happier with lubuntu in the long run anyway. However, I'm happy to continue troubleshooting this, and I can switch between these environments; it would be nice to figure out what's going on. But it's less pressing from my end than when I first posted. I very much appreciate your help!) – Pete Forsyth Mar 20 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.