0

I want to install libdrm-dev package but I get the following issue:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libdrm-dev : Depends: libdrm2 (= 2.4.67-1) but 2.4.91-2~16.04.1 is to be installed
              Depends: libdrm-intel1 (= 2.4.67-1) but 2.4.91-2~16.04.1 is to be installed
              Depends: libdrm-radeon1 (= 2.4.67-1) but 2.4.91-2~16.04.1 is to be installed
              Depends: libdrm-nouveau2 (= 2.4.67-1) but 2.4.91-2~16.04.1 is to be installed
              Depends: libdrm-amdgpu1 (= 2.4.67-1) but 2.4.91-2~16.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

The real issue is that I checked version on synaptic

screenshot for reference

and the currently installed package have all the "is to be installed" version already, how can I fix this? Also installing via synaptic gives me the same error.

  • Ensure that you have xenial-security and xenial-updates enabled, then run sudo apt update and make sure it succeeded, Then try the install again. – user535733 Mar 19 at 16:04
  • i did it and everything worked fine (has to upgrade a lot of other package too after the enabling security and updates) you can post it as an answer because i cant flag this comment as a solution – lost_soul Mar 19 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.