14

Using VirtualBox 6.0. Host Windows 10 Pro, VM: Linux Ubuntu 64 18.04.2. I’m quite a beginner with Linux and haven’t used Virtual Box for years.

I was initially trying to set the resolution for my VM, but got into even worst problems. So, trying to solve one at a time…

I first launched the VM with Ubuntu .iso as virtual drive, installed Ubuntu. Ejected Ubuntu installation virtual disc. Then I inserted the Guest Additions virtual CD ( Devices > Insert Guest Additions CD image … ) Linux told me that this CD has executable content, I told it to run it. All I get then is a black screen.

After a long time, I tried ACPI shutdown and re-started the machine.

I see a Ubuntu loading screen (“Ubuntu” title with 4 dotes below it) then after a short time, a black screen. (Doesn’t seem perfectly black though, it looks like the black with a tiny bit of red used in some Ubuntu screens).

1
  • I have the same problem with VirtualBox 6.1.22 Host Windows 10 Enterprise, VM: Linux Ubuntu 64x 21.04. Using the VM with a single monitor output but having my local machine screen duplicated.
    – Tms91
    Jul 21, 2021 at 13:08

10 Answers 10

13

I had this same exact issue. I solved it by shutting down, going to my virtual machine settings and selecting display. I changed the graphics controller to VBoxVGA, yours might be different, just interchange the available options. I hope this helps

2
  • This turned out not to be the best solution, I ended up creating a new VM
    – Muganwas
    Jul 15, 2019 at 11:30
  • Worked perfectly thanks.
    – Resource
    Mar 25, 2021 at 15:09
4

My display was already set to VBoxSVGA. I got the solution from Ubuntu 18.04 LTS on Virtualbox boots up, but black login screen which was to change the Video Memory from 16MB to 64MB.

1
  • this worked, +1
    – jmarina
    Feb 22, 2021 at 13:32
3

I am running VirtualBox 6.0.14 on host Ubuntu 18.04.2 (Dell laptop). My Debian 9 VM was starting with a completely black, blank screen.

For me, the issue was resolved by changing to:

Display → Graphics Controller → VBoxSVGA

1

I am running VirtualBox 5.2.6 on a Mac OS host. I had to change the number of processors to 2 (Settings->System->Processor) to get the login screen to show up. The default appears to be 1 processor (at least for this version of VirtualBox).

1

Very Late but simply disabled 3d acceleration and VMSVGA as the graphic controller and it worked. The cause of my issue was running out of cd memory + subsequently adding more but then the VM wouldn't open after the logging in(black screen).

also changing boot order to CD worked on a different occasion

1
  • thanks, your witness bring me believe in general this problem is caused by the VM running out of memory
    – Tms91
    Jul 21, 2021 at 12:30
1

In my case the blank, black screen was not caused by VirtualBox settings, it was the GDM mesa shader cache created by the original Ubuntu installation.

I'd imported a VirtualBox 6.1.28 OVA for a VM with Ubuntu 20.04.3 Gnome desktop set up for one user. After the OS boots with the graphical loading screen the screen turns black, occasionally showing the mouse cursor as multiple attempts to start the Gnome greeter login screen fail. In the end there is only a blinking text cursor in the top level corner. I was then able to use + to switch to a tty login.

I (eventually) found the significant failure in the journalctl -b log;

wsone-VirtualBox kernel: traps: gnome-shell[1128] trap invalid opcode ip:7f44240a60d3 sp:7ffe59ab40a0 error:0

which led me (via this post) to the mesa_shader_cache.

The solution that worked for me was to remove the system level and user level mesa shader cache folders;

  $ sudo rm -rf /var/lib/gdm3/.cache/mesa_shader_cache
  $ sudo rm -rf ~/.cache/mesa_shader_cache

After both were removed, the graphical user login screen was displayed on start up and after logging in, the full Gnome desktop created by the original installation was displayed.

1
  • This fixed my issue on Ubuntu 20.04 and VMware Workstation 16! Thank you!
    – Jordan
    Aug 14, 2022 at 17:28
0

I had to disable 3d acceleration underneath the graphics controller selection menu, which I have to set to VMSVGA or I get an error message.

0

go to your display settings, and select VBoxSVGA controller and also disable the 3d acceleration as it is not supported on VBoxSVGA.

0

Copy-pasting from another thread just for the urge to complain.

My problem was that I chose the wrong OS type: I chose Ubuntu 32 bit but my installation was a 64 bit one. After about an hour of fiddling with video memory/display type/HW acceleration/virtualization flags, I finally realized where the catch was. A big thank you to Oracle for not automatically detecting the type of instructions the OS tries to execute thus not helping those who got little sleep the night before.

0

For me, it was the fact of having docker hub opened with some docker containers running that was causing the problem.

I closed docker hub and the running containers and then it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.