After resizing /home directory on my Ubuntu 18.04 (used Gparted while booting from LinuxMint-LiveCD my Ubuntu boots exclusively in emergency mode. What can I do to fix it?

I ran lsblk in emergency mode, and saw that:

  1. my /dev/sda3 (/home) partition was unmounted (its size was changed)
  2. unallocated space presumably still is considered as part of sda device (because sda size is shown as before 931Gb), but not recognized as /dev/sda4 or anyhow.

After mounting /dev/sda3 to the system I am able to start a normal session, but after reboot it happens again.

What can I do to make my Ubuntu boot normally again?

Content of /etc/fstab:

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=d5eb2396-e9df-4a63-84da-d628c915d809 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=3E0D-5C34  /boot/efi       vfat    utf8,umask=007,gid=46 0       1
# /home was on /dev/sda3 during installation
UUID=f79558ec-8e55-4fa5-81ed-b6c77c87a43b /home           ext4    defaults        0       2
/swapfile                                 none            swap    sw              0       0
  • It will help if you add the contents of /etc/fstab and the output of the command blkid to your question Mar 19, 2019 at 13:09
  • 1
    Welcome to AskUbuntu! Unfortunately you've added your blkid output twice and your fstab content not at all. Please copy and paste text rather than posting images of console output. Thank you for helping us help you
    – Elder Geek
    Mar 19, 2019 at 18:28
  • 3
    Welcome to Ask Ubuntu! What are the error messages from the failed boot? Also please do not post screenshots of the terminal. Paste the text directly to your question and apply code formatting.
    – Melebius
    Mar 20, 2019 at 10:11
  • Re. "P.S. I'm sorry for posting images instead of pasting text, I just find it yet confusing to deal with local markup rules. If I'd just pasted output here it would look unreadable, images do the job much better", Please read points 1-5 in this question.
    – DK Bose
    Mar 21, 2019 at 2:25
  • 1
    I'd upvote question if you fixed images of code, that really grinds my gears. Paste code from terminal. Mar 21, 2019 at 4:08

1 Answer 1


I solved the problem in the following manner:

  1. In the emergency mode, I ran journalctl -xb | less and searched for errors.

It appeared that /dev/sda3 couldn't pass control sum check and therefore was refused to be mounted. Fortunately right there was a proposition to run manually fsck /dev/sda3 to fix it.

  1. I ran fsck /dev/sda3 and, in a while, it fixed the problem.

Since then I didn't have problems booting into Ubuntu.

  • Less of a good idea, but another thing that may pass for a possible solution, in a similar case, is to change the value of <pass> parameter from 2 to 0 in /etc/fstab file for the corresponding partition. Then it won't be checked at all by fsck wiki. Probably, maybe handy if certain properties of a partition change very often
    – Ivan K.
    Mar 21, 2019 at 9:08
  • While I understand what you would be doing if you changed the value of <pass> I would not encourage you to do this. Failing the boot fsck indicates that there is a problem with the file system structure, and proceeding further could place the data stored on your disc in danger. Mar 22, 2019 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.