1

I am trying to install php in my ubuntu system, I have already installed apache and mysql, but I am not able to install php using the following command

sudo apt install php libapache2-mod-php

I am receiving the following error:

(Reading database ... 489 files and directories currently installed.)
Preparing to unpack .../libapache2-mod-php_2%3a7.3+69+ubuntu18.10.1+deb.sury.org+2+php7.3_all.deb ...
Unpacking libapache2-mod-php (2:7.3+69+ubuntu18.10.1+deb.sury.org+2+php7.3) ...
Setting up php7.3-common (7.3.3-1+ubuntu18.10.1+deb.sury.org+1) ...
dpkg: error processing package php7.3-common (--configure):
 installed php7.3-common package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of php7.3-opcache:
 php7.3-opcache depends on php7.3-common (= 7.3.3-1+ubuntu18.10.1+deb.sury.org+1); however:
  Package php7.3-common is not configured yet.

dpkg: error processing package php7.3-opcache (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libapache2-mod-php7.3:
 libapache2-mod-php7.3 depends on php7.3-common (= 7.3.3-1+ubuntu18.10.1+deb.sury.org+1); however:
  Package php7.3-common is not configured yet.
 libapache2-mod-php7.3 depends on php7.3-opcache; however:
  Package php7.3-opcache is not configured yet.

dpkg: error processing package libapache2-mod-php7.3 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                    dpkg: dependency problems prevent configuration of php7.3-cli:
 php7.3-cli depends on php7.3-common (= 7.3.3-1+ubuntu18.10.1+deb.sury.org+1); however:
  Package php7.3-common is not configured yet.
 php7.3-cli depends on php7.3-opcache; however:
  Package php7.3-opcache is not configured yet.

dpkg: error processing package php7.3-cli (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of php7.3-readline:
 php7.3-readline depends on php7.3-common (= 7.3.3-1+ubuntu18.10.1+deb.sury.org+1); however:
  Package php7.3-common is not configured yet.

dpkg: error processing package php7.3-readline (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of php7.3:
 php7.3 depends on libapache2-mod-php7.3 | php7.3-fpm | php7.3-cgi; however:
  Package libapache2-mod-php7.3 is not configured yet.
  Package php7.3-fpm is not installed.
  Package php7.3-cgi is not installed.
 php7.3 depends on php7.3-common; however:
  Package php7.3-common is not configured yet.

dpkg: error processing package php7.3 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of php7.3-json:
 php7.3-json depends on php7.3-common (= 7.3.3-1+ubuntu18.10.1+deb.sury.org+1); however:
  Package php7.3-common is not configured yet.

dpkg: error processing package php7.3-json (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libapache2-mod-php:
 libapache2-mod-php depends on libapache2-mod-php7.3; however:
  Package libapache2-mod-php7.3 is not configured yet.

dpkg: error processing package libapache2-mod-php (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of php:
 php depends on php7.3; however:
  Package php7.3 is not configured yet.

dpkg: error processing package php (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 php7.3-common
 php7.3-opcache
 libapache2-mod-php7.3
 php7.3-cli
 php7.3-readline
 php7.3
 php7.3-json
 libapache2-mod-php
 php
E: Sub-process /usr/bin/dpkg returned an error code (1)
0

1 Answer 1

0

While this answer is two years late, this problem can happen when dpkg has remnants of broken/incomplete installations in its info directory. You can usually solve the issue like this:

sudo rm /var/lib/dpkg/info/php*
sudo dpkg --configure -D 777 php
sudo apt -f install

Then again for libapache2-mod-php:

sudo rm /var/lib/dpkg/info/libapache2-mod-php*
sudo dpkg --configure -D 777 libapache2-mod-php
sudo apt -f install

What this is doing:

  • remove the .list and .md5sums files for the affected packages from /var/lib/dpkg/info
  • set dpkg to debug mode so that, if it fails to build, you'll have more specific data to work with, making it easier to find out why the package couldn't install
  • force apt to install the packages (as much as reasonable, anyway)

Hopefully this will help someone in the future who runs into this sort of problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .