24
sudo gsettings set org.gnome.Vino require-encryption false

has already been attempted, but the issue below prevails.

I have a Windows 10 tablet and a Ubuntu desktop (18.04.2 LTS). The Win10 Tablet has a fresh install with nothing but Discord and VNCViewer installed (realvnc.com). Ubuntu is currently using the built-in Sharing from settings. I have tried connecting via the VNC link (pc-name.local), it was forever stuck on connecting. I instead tried the local IP (192.168.0.13), of which resulted in this message:

Unable to connect to VNC Server using your chosen security setting.

I have tried both Ask For Access and a Password. Both yield the same results. Any ways for me to get around this so I can connect from my tablet to Ubuntu? Thank you.

1
  • 2
    any hint on how to connect from realvnc vncviewer to ubuntu without disabling the encryption in the server side? Aug 7 '19 at 22:03
48

Oh, okay! Good news! I found out the issue. I did the command on the top of my question, but this time without sudo. This managed to do the trick, and it works great now! So follow the command above, but do NOT use sudo.

gsettings set org.gnome.Vino require-encryption false

run the command like this, without the sudo.

1
  • I tried to execute this after taking ssh then it shown some errors. later I tried this directly in system ,that time it worked !!
    – Arun
    Nov 22 at 10:58
4

My VNC Server, vino? gnome-remote-desktop-daemon uses tls-anon by default, and it won't respond to gsettings. Here's what worked, install dconf-editor and change this: to include 'none' in encryption type... without the obvious caveats, use SSH tunneling for security. Confirmed working on wayland

enter image description here

source: https://gitlab.gnome.org/jadahl/gnome-remote-desktop/issues/24

1

If the VNC server doesn't require encryption, you must setup the VNC client also to do not use encryption or to let the server choose. For the current version of RealVNC Viewer 6.19 (it is free):

  1. Choice Properties on the connection you want to modify.

    enter image description here

  2. In the General tab, for Encryption set Prefer off or Let VNC Server Choose.

    enter image description here

The above screenshots are from the Linux version of RealVNC Viewer, so they can looks slightly different.

2
  • 8
    Hi, I tried both VNC Server and Prefer off, but unfortunately that did not work. :(
    – Nutik
    Mar 18 '19 at 19:20
  • Didn't work but this worked: Open dconf-editor >>org>>gnome>>desktop>>remote session >> require-encryption false
    – Jonathan
    Aug 4 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.