i have trouble with internal wifi card on my Dell Latitude 5590 runing Ubuntu 16.04 LTS. What happend before problem occured:

  1. I recieved notification that my laptop has updates, updated it, enrolled MOK (as it begged) and everything worked fine.
  2. I decided to remove Code::Blocks, which resulted into this
  3. Restarted pc and Ubuntu lost embedded wifi adapter

sudo lshw -C Network shows

  *-network UNCLAIMED     
       description: Network controller
       product: Wireless 8265 / 8275
       vendor: Intel Corporation

lspci -nn recognizes adapter

02:00.0 Network controller [0280]: 
 Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)

and rfkill list output is

0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: dell-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

As far as i understood the problem is in oem-wifi-intel-iwlwifi-lp1757035-4.4-dkms-dkms, because then i try to reinstall it with sudo apt-get install --reinstall oem-wifi-intel*, it stops, signaling Bad return status for module build on kernel: 4.4.0-143-generic


1 Answer 1


The 4.4 kernel doesn't support your wireless adapter. That is the reason you installed some dkms module with a backport of that driver.

After a kernel update the driver doesn't build, or is blocked by Secure Boot.

I suggest removing that dkms package completely and switch to a HWE kernel that does support your wireless adapter.

First boot with the previous kernel using grub menu. Wi-Fi should work.

Then run in a terminal

sudo apt purge 'oem-wifi-intel.*'
sudo apt install linux-generic-hwe-16.04


  • I just ran commands you gave and everything worked as charm. You are a magician, thank you! Mar 18, 2019 at 18:25
  • If you have an ethernet cable, you should be able to just plug in and run these commands instead of using grub menu to boot into previous kernel.
    – Garrett
    Mar 21, 2019 at 8:51
  • I had to adapt it for matching the current Ubuntu release (currently 18.04), but it does work! Thanks. Here is a generic command to install it: sudo apt install linux-generic-hwe-$(lsb_release -r | cut -f2) Nov 8, 2019 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.