0

I am using Okular 1.3.3 on Ubuntu 18.04 and experiencing problems with the keyboard shortcuts. No shortcuts that use alt or ctrl work now, which is a real pain.

In the 'Configure Shortcuts' tab, when I try and set a custom shortcut like ctrl+z it gives the input as ctrl+alt+z,alt+.... It seems that Okular has suddenly decided to read both ctrl and alt from the same key. A similar thing happens with the alt key, where Meta and alt are conflated.

I have adjusted those keys in GNOME Tweak tools with the option "Left Alt as Ctrl, Left Ctrl as Win, Left Win as Left Alt". But that setting has always been on, and Okular shortcuts had been working fine up until now. The double input problem persists if I turn the setting off (but now the original alt and ctrl keys give the problem) and in any case, the problem occurs with the rightside keys as well.

If I use xev or xbindkeys -k in terminal, the keymaps return the expected single key. It seems this is a problem occuring within Okular as it interprets the keyboard input. And it has occured suddenly without me updating Okular or anything. I tried to uninstall and reinstall Okular but the problem persists.

Has anyone else had this issue with Okular in a GNOME shell?

EDIT Have now noticed that this also occurs in RStudio. It definitely does not happen in other apps that I have tried so far. Why would these two apps in particular be incorrectly interpreting my input?

Are there any other approaches I could use to get to the root of this problem?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.