0

I was trying to dual boot by installing Ubuntu on D:/ partition of my hard disk while as having windows 10 already installed on C:/ partition. So for that I did the following steps to install Ubuntu 18 alongside with windows 10:

  1. Created a bootable USB of Ubuntu 18 LTS with Rufus on windows.
  2. Reboot the system and boot from USB.
  3. Install the Ubuntu by creating necessary partitions (/ /home swap and efi) in ubuntu installation wizard.
  4. Hit install now to install ubuntu. After a while the installation failed and didn't proceed due to some error.

So after unable to install ubuntu I decided to check if windows is working so I rebooted and removed the USB and Guess what ? windows didn't load instead I get error:

No bootable device -- insert boot disk and press any key.

What happened with windows ? Did ubuntu messed with windows bootloader or anything ?

I also tried to Load Setup Defaults from my BIOS configuration but that didn't helped. Does loading to defaults remove windows completely as my laptop came with no operating system pre-installed.

Please help I don't want to format with new windows as I have some data on C:/ and I don't want to install all the softwares all over again. Is there a way to get rid of above error ? With repair or something else ? Any help would be highly appreciated.

Edit:

I tried to install ubuntu again by replacing previous partitions with just swap and / partitions and now when I hit install now it shows a warning message:

No EFI System Partition was found. This system will likely not be able to boot successfully, and the installation process may fail. Please go back and add an EFI System Partition, or continue at your own risk.

My BIOS Configuration:

My BIOS info

I also confirmed that Windows is using BIOS by going to C:/Windows/Panther/setupact.log in my ubuntu live USB and finding a line saying IBS Callback_BootEnvironmentDetect: Detected boot environment: BIOS

Moreover I ran sudo gdisk -l /dev/sda and I got the output as:

output of gdisk

The EFI System in the above photo was created when installing Ubuntu the first time which didn't succeed.

After Using Boot-Repair from my ubuntu live USB I now get Missing Operating System error.

What I can understand (correct me if I am wrong). My windows 10 was installed with BIOS mode. While as I tried to install Ubuntu 18 LTS 64bit alongside with windows 10 which failed to install but created an EFI partition on my disk. Now the reason I cannot boot into windows 10 is because it looking into EFI partition (as it has first priority than BIOS mode) which maybe corrupted. That is why windows 10 doesn't boot.

I removed the EFI system partition and other linux partitions using gparted now I am getting no error but just a black screen with blinking cursor.

  • Comments are not for extended discussion; this conversation has been moved to chat. – Mitch Mar 17 at 7:18
  • Your LDM partitions are Windows proprietary Logical or dynamic partitions. Most say not to use dynamic partitions when dual booting. It used to be, that Ubuntu did not have any driver for dynamic partitions and would not show drive. Best to remove the LDM.askubuntu.com/questions/482768/… – oldfred Mar 17 at 18:00
  • @oldfred I can do it later. I first need to boot into windows. How would I do it ? Please help – Ahtisham Mar 17 at 19:22
  • With UEFI you boot Windows directly from UEFI boot menu. If that does not work then just a Windows issue as grub/ubuntu not involved. You may need f8 for internal repair console or your Windows repair disk to fix Windows. It always needs chkdsk after a resize so we do not suggest using gparted on NTFS, only Windows & immediate reboot to run chkdsk. – oldfred Mar 17 at 20:50
  • How would you boot from UEFI boot menu ? Also as I mentioned my windows was BIOS not UEFI. I ran Boot-Repair in Ubuntu and now instead of No bootable device I get Missing Operating System. So I opened gparted and deleted partitions containing ubuntu files. Then I tried windows startup repair which says error Cannot repair so I opened diskpart in cmd and did active after selecting a partition and assign after selecting a volume. Now I am getting no error but a black screen with a blinking cursor. What to do next ? – Ahtisham Mar 18 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.