2

I'm removed windows 10 from my laptop (hp probook x360) and i tried to install Lubuntu on it, but it was hang on 81% during the installation. So I tried to install Ubuntu but the installation does not go further than "installing the 'grub2' package..." I made my searches on forums but I am a total newbie so I can't fix it.

I checked the MD5sum and it's OK.

Version:

Ubuntu 18.04.2 LTS

sudo parted -ls:

ubuntu@ubuntu:~$ sudo parted -ls
Model: ATA SAMSUNG MZNLN128 (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                  Flags
 1      1049kB  538MB   537MB   fat32           EFI System Partition  boot, esp
 2      538MB   1612MB  1074MB  ext4
 4      1612MB  124GB   122GB                                         lvm
 3      124GB   128GB   3940MB  linux-swap(v1)  ANTERGOS_SWAP


Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdb: 31.3GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  31.3GB  31.3GB  primary  fat32        boot, lba


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/fedora-home: 64.7GB
Sector size (logical/physical): 512B/4096B
Partition Table: loop
Disk Flags: 

Number  Start  End     Size    File system  Flags
 1      0.00B  64.7GB  64.7GB  ext4


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/fedora-swap: 4077MB
Sector size (logical/physical): 512B/4096B
Partition Table: loop
Disk Flags: 

Number  Start  End     Size    File system     Flags
 1      0.00B  4077MB  4077MB  linux-swap(v1)


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/fedora-root: 53.7GB
Sector size (logical/physical): 512B/4096B
Partition Table: loop
Disk Flags: 

Number  Start  End     Size    File system  Flags
 1      0.00B  53.7GB  53.7GB  ext4

I just have a 128GB ssd and a 32GB USB stick which is the installation media. I would like also to let you know that I did a lot of manipulations without understanding them, so it's normal if the disks/partitions contains weird things.

Boot mode:

ubuntu@ubuntu:~$ test -d /sys/firmware/efi && echo efi || echo bios
efi
3
  • Which version of Ubuntu are you trying to install? Did you check with md5sum, that the downloaded iso file is good? In which mode is the computer booted (UEFI or BIOS)? Which alternative did you select at the partitioning page of the installer? What partition table is there, MSDOS or GUID (GPT)? Please ask in a comment, if you need help to answer my questions. Please edit your original question and put your answers there. -- Maybe it is best to let Lubuntu or Ubuntu use the whole drive (which will erase everything and start anew). – sudodus Mar 16 '19 at 17:20
  • I downloaded the ubuntu ISO a few days ago. How can I check the md5sum ? The version is 18.04.2 or 18.10 i do not know . I don't know msdos or guid (I do not even know what does this mean). I created the bootable media with RUFUS , and it allows me to choose MBR or GPT: what should I choose ? And yes I want to erase full disk. – hazonlinux Mar 16 '19 at 18:10
  • @tatsu can you please give me the code to manually do this in terminal? – Spizzy84 Jun 27 '19 at 9:29
0

Getting detailed information

Usually you will see the version in the name of the downloaded iso file. Otherwise you will see it, when booted from the USB drive with the command line

lsb_release -a

You can check the md5sum with the program md5sum,

md5sum filename.iso

and compare to the listed value in the file MD5SUMS, that you find in the same directory as the corresponding iso file. You find it via this link,

releases.ubuntu.com/

The partition table, MSDOS or GUID (GPT), is listed in the output of the following command. See the output for the internal drive, where you intend to install Ubuntu or Lubuntu, and also for the USB pendrive,

sudo parted -ls

Rufus has a good reputation. When you know the partition table (of the USB pendrive) you can choose the option in Rufus.

You can find which boot mode that is used in the computer with the following command,

test -d /sys/firmware/efi && echo efi || echo bios

Please edit your original question and put your answers there. Please make the output of the commands easier to read by indenting each line 4 spaces to render it as 'code'.

Then you can write a comment, that you start with @sudodus in order to send an alert to me, and I can continue helping you (unless I have gone to bed; I have Central European Time; but then someone else might chip in and help you).

Suggested method to make a successful installation

Boot into the Ubuntu live drive 'Try Ubuntu' (still in UEFI mode)

Remove the current partition table and data, that might confuse the installer

Install mkusb in Ubuntu live (yes, I know, that it will not persist a reboot, but you can use it as long as you run the live system).

sudo add-apt-repository universe  # only for standard Ubuntu

sudo add-apt-repository ppa:mkusb/ppa  # and press Enter
sudo apt-get update
sudo apt-get install mkusb mkusb-nox usb-pack-efi
  • Use mkusb-dus to wipe the first mibibyte. In a terminal window,

    dus
    

    and follow the instructions in the menus.

Create a new partition table

  • Start gparted,
  • Select the correct drive (the internal drive) in the small box at the top right corner
  • In the dropdown menu 'Device',
    • select 'Create partition table' and
    • gpt
    • and click the Apply button.

I think this is enough in gparted. Now there should be a GUID partition table (but no partitions yet).

Start the installer

  • Start as before ...
  • At the partitioning window of the installer,

    The 'Installation type' screen is displayed

    • Select Erase disk and install Ubuntu
  • Continue, and I think it should work to install grub.

Good luck :-)

2
  • Comments are not for extended discussion; this conversation has been moved to chat. – Mitch Mar 17 '19 at 11:49
  • @hazonlinux, then there is some other problem. Please check the S.M.A.R.T. information according to this link, and check the memory with memtest (The version in the Ubuntu live system works only when you boot in BIOS mode.) You can also try with Ubuntu 18.04.1 LTS. I use that version and it works well for me, live, during installation and as installed system. – sudodus Mar 17 '19 at 11:51
0

the number one cause is that you're trying to install on what used to be a windows system but you didn't tell windows to unlock the SSD first.

grub is trying to write to the boot sector and meeting a drive with a read-only flag enabled. Which windows 10 systematically sets on shutdown to allow itself a faster boot in detriment anything else's ability to write to the disk while windows is powered off.

since there is no more windows to do the easy powercfg method, you can instead unlock the drive from the usb boot stick.

mounting the drive from the terminal gives you commands to type if you want write access as well.

or a simpler approach is just to use gparted go into the flags section of the drive and remove everything, then format it entirely to "unformated" for example. then you can start the install prrocess over again.

2
  • 1
    there is no more operating system on the computer – hazonlinux Mar 17 '19 at 11:09
  • then you might still have that flag on the ssd. use the usb lubuntu / ubuntu boot media to boot to and use gparted to remove any suspicious flags from the drive and reformat it completely. – tatsu Mar 17 '19 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.