0

I use a machine with Xubuntu and I installed i3 on it. When I log in in i3 and open thunar the icons are missing. I read that I have to set the icon set in xfce4-settings-manager > Appearance. The icon set is elementary Xfce darker. When I log in in Xfce it works. Why can't this icon set be loaded in i3?

1

Well, since xfce isn't being used the settings manager isn't either. To set an icon theme or gtk-2 theme create the following file in your /home/user: .gtkrc-2.0 . In it set the icon theme with the following line: gtk-icon-theme-name = "elementary-xfce-darker". a gkt-2 theme would be set in the same file with gtk-theme-name = "theme-name". The theme names need to be identical to the names in /usr/share/icons or /usr/share/themes. Using gtk-icon-theme-name = "elementary Xfce darker" would not work.

  • Great explanation with solution. Can this settings cause problems when I go back to xfce? The file .gtkrc-2.0 already existed and contained only include .gtkrc-xfce. I appended your settings. – Thomas Sablik Mar 16 at 23:50
  • 1
    I think it could, but I'm not sure. This was tested on Xubuntu-18.04. In my version there was no .gtk-2.0 file made before I made it, so there was no include .gtkrc-xfce in .gtkrc-2.0. Neither is there a file .gtkrc-xfce on the system I tested with. As long as you don't change icon or theme settings when you are logged into xfce there should be no problem. If you were to encounter a problem, commenting out the added lines in .gtkrc-2.0 and logging back in should remedy the problem. (put a # before gtk-icon-theme-name = "iconthemename" or other line and leave the include line). Kind regards – jeroen Mar 17 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.