14

I am using Ubuntu 11.10 with "Gnome classic (no effects)" at login. Using alt+tab cycles between windows on current desktop. How can I set it to cycle through ALL open windows?


Well, I have done as proposed, here is what happened: when I pressed Alt+Tab, it still showed only window icons from current desktop. Furthermore, I could only switch between the two most recently used windows with a single Tab press. Releasing the Tab and pressing again closed the window chooser.

Another try after logout-login gave another result: pressing Alt+Tab just showed the main menu.

More ideas are welcome.

7
+50

A bug has been reported to Launchpad on this issue. Until it's resolved, install Compiz Config Settings Manager, then use the "Scale" settings there to set ALT-TAB as you want it. Works nicely, actually.

5

I had the same problem.

Looking in System SettingsKeyboardShortcutsNavigation, I realized that Alt+Tab combination was assigned to two different options:

  • Moving through applications
  • Change windows directly

(My system is in Spanish, so I hope the translations are accurate enough)

Assigning a new combination to the last one solved my problem! I hope this helps you.

  • didnt work for me . I am on 12.04, 32bit with gnome-classic settings. – Abhinav Oct 12 '13 at 19:01
5

Under "System Settings > Keyboard > Shortcuts > System > Show the activities overview" you can set alt+tab, which then should cycle through all open windows and applications, on all workspaces, no matter if active/in use or inactive.

I tested it in Gnome-Classic and it works fine! Please let us know, if that solves your problem!

sh


Edit: Gnome Shell Extensions that might do the job:

  • No, this did not work for me. – Yossi Gil May 26 '12 at 12:48
  • didnt work for me as well .. :( – Abhinav Oct 12 '13 at 18:58
2

What I did:

Alt+F2 -> dconf-editor -> Enter
org -> gnome -> desktop -> wm -> keybindings -> switch-applications ['<Super>Tab']
org -> gnome -> desktop -> wm -> keybindings -> switch-applications-backwards ['<Shift><Super>Tab']
org -> gnome -> desktop -> wm -> keybindings -> switch-windows ['<Alt>Tab']
org -> gnome -> desktop -> wm -> keybindings -> switch-windows-backwards ['<Shift><Alt>Tab']

Note, this is the default:

org -> gnome -> desktop -> wm -> keybindings -> switch-applications ['<Super>Tab','<Alt>Tab']
org -> gnome -> desktop -> wm -> keybindings -> switch-applications-backwards ['<Shift><Super>Tab','<Shift><Alt>Tab']
org -> gnome -> desktop -> wm -> keybindings -> switch-windows ['']
org -> gnome -> desktop -> wm -> keybindings -> switch-windows-backwards ['']

protected by Braiam Feb 15 '14 at 0:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.