0

I'm having problems with the printers: 1) in Settings > Devices > Printers I get a screen saying "Sorry! The system printing service doesn't seem to be available".

2) CUPS does not seem to find any local network printer.

I have reinstalled and restarted both CUPS and hplip several times and restored the default cups conf file, but this does not seem to solve the issues.

CUPS seems active and working:

systemctl status cups.service

gives

cups.service - CUPS Scheduler
Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2019-03-15 11:17:17 CET; 10s ago
 Docs: man:cupsd(8)
Main PID: 4329 (cupsd)
  Tasks: 3 (limit: 4915)
  CGroup: /system.slice/cups.service
       ├─4329 /usr/sbin/cupsd -l
       ├─4332 /usr/lib/cups/notifier/dbus dbus://
       └─4333 /usr/lib/cups/notifier/dbus dbus://

and systemctl status cups.socket

gives

 Failed to dump process list, ignoring: No such file or directory
 ● cups.socket - CUPS Scheduler
 Loaded: loaded (/lib/systemd/system/cups.socket; enabled; vendor preset: enabled)
 Active: active (running) since Fri 2019-03-15 11:17:17 CET; 8min ago
 Listen: /run/cups/cups.sock (Stream)
 CGroup: /system.slice/cups.socket

 mar 15 11:17:17 ilaria-XPS-13-9360 systemd[1]: Stopping CUPS Scheduler.
 mar 15 11:17:17 ilaria-XPS-13-9360 systemd[1]: Listening on CUPS Scheduler.

`

any suggestion on what can be wrong? thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.