0

I just installed Ubuntu 18.04.2 LTS, however, I cannot use the Intel Corporation Wireless 72600 (Wireless-N 7260) component.

I´m getting this error message: No Wi-Fi Adapter Found.

Could you please assist?

I cannot access the internet.

For more information or further details, please see the outputs below.

lspci

carlos@carlos-Dell-System-Inspiron-15-7000-Series-7537:~$ lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Network controller: Intel Corporation Wireless 7260 (rev 63)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
03:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
carlos@carlos-Dell-System-Inspiron-15-7000-Series-7537:~$

lshw -C network

carlos@carlos-Dell-System-Inspiron-15-7000-Series-7537:~$ lshw -C network
WARNING: you should run this program as super-user.
  *-network DISABLED        
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 63
       serial: 0c:8b:fd:11:12:23
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.18.0-15-generic firmware=17.948900127.0 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:46 memory:d0500000-d0501fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.1
       bus info: pci@0000:03:00.1
       logical name: enp3s0f1
       version: 12
       serial: 78:45:c4:c9:f5:fa
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8411-2_0.0.1 07/08/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 ioport:3000(size=256) memory:d0404000-d0404fff memory:d0400000-d0403fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
carlos@carlos-Dell-System-Inspiron-15-7000-Series-7537:~$

rfkill list

carlos@carlos-Dell-System-Inspiron-15-7000-Series-7537:~$ rfkill list
0: dell-rbtn: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
carlos@carlos-Dell-System-Inspiron-15-7000-Series-7537:~$

cat /etc/modprobe.d/blacklist-dell-rbtn.conf

carlos@carlos-Dell-System-Inspiron-15-7000-Series-7537:~$ cat /etc/modprobe.d/blacklist-dell-rbtn.conf

carlos@carlos-Dell-System-Inspiron-15-7000-Series-7537:~$
2
  • Please edit your question and add output of rfkill list terminal command. – Pilot6 Mar 15 '19 at 5:34
  • Please read the answer again and try to run the command till you don't have an empty conf file. It looks like you fail to run the command properly. – Pilot6 Mar 15 '19 at 7:33
0

Your wireless adapter is blocked by rfkill.

Check if there is a physical switch that may be off, or a BIOS setting.

In case there is no way to switch it on, you can disable dell-rbtn by running

sudo tee /etc/modprobe.d/blacklist-dell-rbtn.conf <<< "blacklist dell_rbtn"

This is ONE COMMAND. Please don't run it partially.

Reboot to apply.

10
  • I just followed these steps: Steps · Enter sudo tee /etc/modprobe.d/blacklist-dell-rbtn.conf · Enter my password It looks like the terminal is stuck. Any advice? – Carlos Alberto Chaves Morales Mar 15 '19 at 6:33
  • I had to close the terminal, however; I checked the modprobe.d folder and blacklist-dell-rbtn.conf was there. After that, I rebooted, however; the issue persist. Any advice? – Carlos Alberto Chaves Morales Mar 15 '19 at 6:47
  • Why did you run only a part of the command? That's why it didn't work. – Pilot6 Mar 15 '19 at 6:47
  • I just followed these steps: Steps · Enter sudo tee /etc/modprobe.d/blacklist-dell-rbtn.conf <<< "blacklist dell_rbtn" · Reboot the device. The issue persist. Any advice? – Carlos Alberto Chaves Morales Mar 15 '19 at 7:02
  • Did rfkill list output change? – Pilot6 Mar 15 '19 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.