1

I managed to upgrade CMake on my PC following this link How to upgrade cmake in Ubuntu . But now I want to upgrade CMake on my Nvidia Jetson TX2 which is ARM architecture based and the steps on that link doesn't work (only works well with x86).
1 of Nvidia moderator confirms it, see https://devtalk.nvidia.com/default/topic/1048533/jetson-tx2/how-to-install-cmake-3-8-in-jetson-tx2-/post/5321354/?offset=3#5321357 .

My current CMake version is 3.5.1 because it was installed using sudo apt-get install cmake and I need to install the latest version of CMake. Anyone has experience of upgrading CMake to the latest version in ARM based Ubuntu like Jetson TX2?

2

Solved. I have built CMake from source using these steps:

sudo apt remove cmake
wget https://cmake.org/files/v3.8/cmake-3.8.2.tar.gz
tar xf cmake-3.8.2.tar.gz
cd cmake-3.8.2
./configure
sudo make install
cmake --version

If after cmake --version cmake is still not found, we have to add the installed cmake bin directory path in .bashrc:

vim ~/.bashrc
export PATH=/home/ubuntu/cmake-3.8.2/bin
#save
source ~/.bashrc
cmake --version
1
  • You forgot to do tar -xf cmake-3.8.2.tar.gz after the wget to decompress and untar your .tar.gz file. – dddJewelsbbb Jun 28 '19 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.