2

Laptop:DELL inspiron 15 3521 (from 2014), BIOS version A12 OS: Xubuntu 16.04.6 , Kernel: 4.4.0-141-generic. I tried everything I found on internet (almost all of them are old posts +- 5,6 years-old) with no success! The only way for me is to introduce a pin on CD drive hole to pull up the tray. The CD drive works, it's recognized by the system, I can play and so on. Is there a fix to this issue ? I attached a output from (sudo eject -rv) command. Appreciate some help. "eject -rv" output

4
  • Have you unmount it? Ejecting can be locked if device is busy with mount.
    – LeonidMew
    Mar 14, 2019 at 20:48
  • @LeonidMew I think so, but if I didn't unmount how to check if the device is busy with mount? Mar 14, 2019 at 21:01
  • mount command shows all mounted devices
    – LeonidMew
    Mar 14, 2019 at 21:10
  • ok, the output of mount command is a little long, what I have to look for ? sr0 , cdrom , cd , dvd , ... I can use grep for that. Mar 14, 2019 at 23:18

1 Answer 1

0

On my system the simpliest eject command (without arguments) ejects DVD normally.

But with your command eject -rv you have specified implicit use of -r command and -v for verbose output (see man eject for details):

There are four different methods of ejecting, depending on whether the device is a CD-ROM, SCSI device, removable floppy, or tape. By default eject tries all four methods in order until it succeeds.
...
-v This makes eject run in verbose mode; more information is displayed about what the command is doing.
...
-r This option specifies that the drive should be ejected using a CDROM eject command.

So your device may not support this command set.

On my system I see that eject -s works, it means using SCSI command set:

-s This option specifies that the drive should be ejected using SCSI commands.


You can also try with Gnome Disks (gnome-disks): find CD/DVD drive icon here, click on stop button below partitions in the right then click Eject:

gnome-disks

Markings:

  1. stop button with hint Unmount selected partition
  2. eject button with hint Eject this device

Info:

  • the Device field indicates that it is /dev/sr0 (for my system)
  • clicking Eject button really eject tray, I'm running Linux kernel 4.4.0-138-generic if it matters.
  • yesterday I tried the same with internal IDE DVD-RW drive and same kernel and it worked as expected.
3
  • @NOrbert it's not working, eject -s gives -> eject: unable to eject, last error: Success, and from Gnome Disks I got again an error -> Command-line eject /dev/sr0 exited with non-zero exit status 1 (udisks-error-quark, 0) Mar 15, 2019 at 16:12
  • One remark : CD-ROM drive has no Disc , it's empty. Mar 15, 2019 at 16:14
  • maybe I have to update and upgrade my system to see whether or not makes differences, or it's a mechanical issue.thanks Mar 15, 2019 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.