When I type the keybinding sequence Ctrl + Shift + e I'm getting eEEEE. This allows me to specify an emoji, but I need Ctrl + Shift + e for use in VIM.

How can I disable this keybinding. I've already tried running ibus-setup to remove the emoji launcher, but I still get the eEEEE.

This is what happens in xed when I type "ctrl-shift-e"


6 Answers 6


In terminal type ibus-setup, go to the Emoji tab, and delete/change the keybindings.


  • This fixed all my ctrl-shift shortcuts in Terminator. Thanks!
    – forgetso
    Commented Apr 6, 2021 at 20:37
  • This didn't solve it for me on Kubuntu, KDE Plasma, X11, VSCodium snap (it was still using the original key shortcuts even after remapping). The command-line answer worked.
    – geekley
    Commented Nov 29, 2021 at 23:40
  • I had to run sudo ibus-setup
    – Milan
    Commented Nov 8, 2022 at 18:48

For VS Code if installed via Ubuntu Snap you need an input method other than ibus.

If you run VS Code from command line do:

$ GTK_IM_MODULE="xim" code

You can also add an alias for that in .bashrc: alias code='GTK_IM_MODULE="xim" code'

To configure the Dash launcher (assuming VS Code is installed using Snap):

  • The launcher file is located at /var/lib/snapd/desktop/applications/code_code.desktop or ~/.local/share/applications/code_code.desktop, or both
  • Edit it and add GTK_IM_MODULE="xim" to Exec commands:
[Desktop Entry]
Exec=env GTK_IM_MODULE="xim" BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/code_code.desktop /snap/bin/code --force-user-env --no-sandbox --unity-launch %F

[Desktop Action new-empty-window]
Exec=env GTK_IM_MODULE="xim" BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/code_code.desktop /snap/bin/code --force-user-env --no-sandbox --new-window %F

  • Looks like this question could be a dupe of the other one you answered (or vice versa)
    – Zanna
    Commented Aug 22, 2020 at 16:35
  • 2
    Just filed a bug report for codium snap: github.com/snapcrafters/codium/issues/13
    – geekley
    Commented Nov 29, 2021 at 23:37
  • The file at /var/lib/snapd/desktop/applications/code_code.desktop was overwritten by the system and reverted back to deafaults. Copying to ~/.local/share/applications/code_code.desktop and editing it there works more reliably in 22.04.
    – anpel
    Commented Aug 11, 2022 at 12:08

I had the same problem, but for VS Code. The ibus solution didn't work for me. What worked is:

$ GTK_IM_MODULE="xim" code

Make sure that you close all VS Code windows before running this.

However, I have tested this for vim and it didn't work there - not sure why. There is a nice explanation of the concepts here and a relevant VS Ccode bug (with mitigations) here.

  • Worked on Ubuntu 18.04. You can add an alias in your .bashrc file: alias code='GTK_IM_MODULE="xim" code'.
    – zardosht
    Commented Aug 22, 2020 at 15:01
  • 3
    I simply added export GTK_IM_MODULE="xim" to my .profile which fixed the problem in all apps
    – maackle
    Commented Sep 23, 2020 at 2:56
  • Ubuntu 21 this is the solution that worked for me
    – lordvcs
    Commented May 1, 2021 at 12:48

Like kuceb answer but using CLI, changing to Ctrl + Shift + Super + e:

gsettings set org.freedesktop.ibus.panel.emoji hotkey $'[\'<Control><Super><Shift>e\']'

This is a bug listed here:


The solution that I found is to remove the ibus package:

$ sudo apt-get remove ibus
$ sudo apt-get purge ibus

Go to updates and set the repository for focal fossa version for Ubuntu and remove the remanescent eoan

Go to updates and set the repository for focal fossa version for Ubuntu and remove the remanescent eoan and reinstall ibus:

sudo apt-get install ibus

Go to language suport and set the iBus method, for user and root

In the terminal for user and root:


and change the shortcuts in the emoji tab

In the terminal for user and root:


and set ibus

For user in the terminal:

gedit .bashrc

Include the following lines at the end:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

Open Ibus preferences in your launcher, visit the Emoji tab, then click the ... beside Emoji Annotation to either Delete or change the shortcut:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .