42

When I type the keybinding sequence ctrl-shift-e I'm getting eEEEE. This allows me to specify an emoji, but I need ctrl-shift-e for use in VIM.

How can I disable this keybinding. I've already tried running ibus-setup to remove the emoji launcher, but I still get the eEEEE.

This is what happens in xed when I type "ctrl-shift-e"

2
37

In terminal type ibus-setup, go to the emoji tab, and delete the keybindings.

2
  • This fixed all my ctrl-shift shortcuts in Terminator. Thanks!
    – forgetso
    Apr 6 at 20:37
  • This didn't solve it for me on Kubuntu, KDE Plasma, X11, VSCodium snap (it was still using the original key shortcuts even after remapping). The command-line answer worked.
    – geekley
    Nov 29 at 23:40
14

For VS Code if installed via Ubuntu Snap you need an input method other than ibus.

If you run VS Code from command line do:

$ GTK_IM_MODULE="xim" code

You can also add an alias for that in .bashrc: alias code='GTK_IM_MODULE="xim" code'

To configure the Dash launcher (assuming VS Code is installed using Snap):

  • The launcher file is located at /var/lib/snapd/desktop/applications/code_code.desktop or ~/.local/share/applications/code_code.desktop, or both
  • Edit it and add GTK_IM_MODULE="xim" to Exec commands:
[Desktop Entry]
...
Exec=env GTK_IM_MODULE="xim" BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/code_code.desktop /snap/bin/code --force-user-env --no-sandbox --unity-launch %F
...

[Desktop Action new-empty-window]
...
Exec=env GTK_IM_MODULE="xim" BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/code_code.desktop /snap/bin/code --force-user-env --no-sandbox --new-window %F
Icon=/snap/code/41/meta/gui/com.visualstudio.code.png


2
6

I had the same problem, but for VS Code. The ibus solution didn't work for me. What worked is:

$ GTK_IM_MODULE="xim" code

Make sure that you close all VS Code windows before running this.

However, I have tested this for vim and it didn't work there - not sure why. There is a nice explanation of the concepts here and a relevant VS Ccode bug (with mitigations) here.

3
  • Worked on Ubuntu 18.04. You can add an alias in your .bashrc file: alias code='GTK_IM_MODULE="xim" code'.
    – zardosht
    Aug 22 '20 at 15:01
  • 2
    I simply added export GTK_IM_MODULE="xim" to my .profile which fixed the problem in all apps
    – maackle
    Sep 23 '20 at 2:56
  • Ubuntu 21 this is the solution that worked for me
    – lordvcs
    May 1 at 12:48
0

This is a bug listed here:

https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1885914

The solution that I found is to remove the ibus package:

$ sudo apt-get remove ibus
$ sudo apt-get purge ibus

Go to updates and set the repository for focal fossa version for Ubuntu and remove the remanescent eoan

Go to updates and set the repository for focal fossa version for Ubuntu and remove the remanescent eoan and reinstall ibus:

sudo apt-get install ibus

Go to language suport and set the iBus method, for user and root

In the terminal for user and root:

ibus-setup

and change the shortcuts in the emoji tab

In the terminal for user and root:

im-config

and set ibus

For user in the terminal:

gedit .bashrc

Include the following lines at the end:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
0

Open Ibus preferences in your launcher, visit the Emoji tab, then click the ... beside Emoji Annotation to either Delete or change the shortcut:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.