5

When I start Bluetooth Manager, I get this

Connection to Bluez failed.
bluez daemon is not running, blueman-manager cannot continue...

I tried re-installing bluez and blueman.

I have several dongles that I am trying to troubleshoot.

sudo /etc/init.d/bluetooth status
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:bluetoothd(8)

sudo rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
8
  • 3
    Try sudo /etc/init.d/bluetooth start and see if it brings the daemon up. – Parto Mar 15 '19 at 6:29
  • @Parto [ ok ] Starting bluetooth (via systemctl): bluetooth.service. – fixit7 Mar 15 '19 at 7:46
  • 2
    Does it solve the problem? – Parto Mar 15 '19 at 7:47
  • No, I still can not start bluetooth manager. – fixit7 Mar 15 '19 at 7:54
  • Does your computer have a physical wireless switch? You can try pressing it. There is a chance your wifi and bluetooth are hard blocked. – Parto Mar 15 '19 at 13:08
3

Starting the Bluetooth Manager while bluetooth is disabled brings up this error message.

Connection to BlueZ failed

The fix is to start up the bluetooth service via terminal with the command below:

NOTE: Don't type the $ in the command below, it is used to show the terminal prompt and the terminal response below it showing that bluetooth service has been started successfully.

$ sudo /etc/init.d/bluetooth start
[ ok ] Starting bluetooth (via systemctl): bluetooth.service.

Once the bluetooth service has been started, starting the Bluetooth Manager again brings this window up:

Bluetooth turned off

In which case, just press the Enable Bluetooth button to enable bluetooth and start the main window as seen below.

Bluetooth Manager main window

Finally, search and add your bluetooth devices using the Search button on the top left corner.

6
  • 1
    I did exactly what you posted. I still get the same message, Connection to Bluez failed. @Parto – fixit7 Mar 15 '19 at 12:48
  • 1
    @fixit7 Do you get any other error message? Give me some details I can work with – Parto Mar 15 '19 at 12:51
  • When I run it via system,preferences,hardware I get exactly this. Connection to BlueZ failed. Bluez daemon is not running, blueman manager can not continue. This probably means that there are no Bluetooth adaptors detected or Bluetooth damon was not started. And a Close box. I am doing my best to help you. – fixit7 Mar 15 '19 at 12:54
  • 1
    it is cool. Edit the question and include the output of sudo /etc/init.d/bluetooth status and sudo rfkill list – Parto Mar 15 '19 at 12:59
  • 1
    I used sudo service bluetooth start instead of sudo /etc/init.d/bluetooth start. Use of service seems more suitable for new linux versions. – Sir Jo Black May 7 '20 at 6:42
2

I recently added a FitBit dongle. I decided to unplug it.

Bluetooth manager started without any error message.

2
  • 1
    Oh, cool. Weird that it affects bluetooth. Try running sudo rfkill list and see if you can see bluetooth in the list. – Parto Mar 15 '19 at 13:11
  • 1
    You can accept this answer, let me give you a +1, it has been an interesting question. – Parto Mar 15 '19 at 13:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.